
For the best experience, open this PDF portfolio in
Acrobat 9 or Adobe Reader 9, or later.

Get Adobe Reader Now!

http://www.adobe.com/go/reader




Adobe Rich Media Communication using Flash CS4  1 of 2 
©2009 Adobe Systems Incorporated 


Adobe Rich Media Communication using Flash CS4 
EXAM AND OBJECTIVES 


After taking the exam, your score is electronically reported.  Please allow 2-4 weeks from the date you pass the exam to 
receive your ACA Welcome Kit. 


Exam Structure 
The following lists the topic areas covered in the exam:  


• Setting project requirements  
• Identifying rich media design elements  
• Understanding Adobe Flash CS4 Interface  
• Building rich media elements by using Flash CS4 
• Evaluating rich media elements by using Flash CS4 
• Number of Questions, Time and Passing Score  


 
 
Number of Questions, Time and Passing Score  


• Ranges from 35-40 questions 


• Allow for up to 60 minutes to test 


 
Exam Objectives 
Domain 1.0 Setting Project Requirements 


1.1 Identify the purpose, audience, and audience needs for rich media content. 


1.2 Identify rich media content that is relevant to the purpose of the media in which it will be used (websites, mobile 
devices, and so on). 


1.3 Understand options for producing accessible rich media content. 


1.4 Demonstrate knowledge of standard copyright rules (related terms, obtaining permission, and citing copyrighted 
material).  


1.5 Understand project management tasks and responsibilities. 


1.6. Communicate with others (such as peers and clients) about design and content plans 


 
Domain 2.0 Identifying Rich Media Design Elements 


2.1 Identify general and Flash-specific best practices for designing rich media content for a website. 


2.2 Demonstrate knowledge of design elements and principles. 


2.3 Identify general and Flash-specific techniques to create rich media elements that are accessible and readable. 


2.4 Use a storyboard to produce rich media elements. 


2.5 Organize a Flash document 


 
Domain 3.0 Understanding Adobe Flash CS4 Interface 


3.1 Identify elements of the Flash interface. 


3.2 Use the Property inspector. 


3.3 Use the Timeline. 


3.4 Use the Motion Editor. 


3.5 Understand Flash file types. 


3.6 Identify best practices for managing the file size of a published Flash document. 
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Domain 4.0 Building Rich Media Elements by Using Flash CS4 


4.1 Make rich media content development decisions based on your analysis and interpretation of design specifications. 


4.2 Adjust document properties. 


4.3 Use Flash guides and rulers. 


4.4 Use tools on the Tools panel to select, create, and manipulate graphics and text. 


4.5 Import and modify graphics. 


4.6 Create text. 


4.7 Adjust text properties. 


4.8 Create objects and convert them to symbols, including graphics, movie clips, and buttons. 


4.9 Understand symbols and the library. 


4.10 Edit symbols and instances 


4.11 Create masks. 


4.12 Create animations (changes in shape, position, size, color, and transparency). 


4.13 Add simple controls through ActionScript 3.0. 


4.14 Import and use sound. 


4.15 Add and export video. 


4.16 Publish Flash documents. 


4.17 Make a document accessible 


  
Domain 5.0 Evaluating Rich Media Elements by Using Flash CS4 


5.1 Conduct basic technical tests. 


5.2 Identify techniques for basic usability tests. 
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Dear Candidate, 


In preparation for the Rich Media Communication certification exam, we’ve put together a set of 


practice materials and example exam items for you to review.  What you’ll find in this packet are: 


 Topic areas and objectives for the exam.  


 Practice materials with image assets. 


 Practice exam items. 


We’ve assembled excerpted material from the Digital Design Curriculum guide to highlight a few of the 
more challenging techniques covered on the exam.  You can work through these technical guides with 
the provided image and video files (provided separately). Additionally, we’ve included the certification 
objectives so that you are aware of the elements that are covered on the exam. Finally, we’ve included 
practice exam items to give you a feel for some of the items.  


These materials are meant to help you familiarize yourself with the areas of the exam so are not 
comprehensive across all the objectives. 


Thank you, 


Adobe Education 












Practice Exam  
Try out these practice questions to get a feel for the types of questions on the ACA exam. Please note that 
your performance here does not indicate how you will do on the actual exam. The actual exam is 
approximately one-half multiple-choice questions similar to the questions in this document, and 
approximately one-half simulation questions where you will be asked to perform a task in the Flash CS4 
application. To fully prepare for the exam, closely review the topic areas and objectives.  
 
1. Which SWF file elements can be made accessible by screen readers? (Choose two.) 


A. Buttons  
B. Key frames  
C. Dynamic text  
D. Static text  


 
Correct answer: A and D  
 
2. What changes are possible through the Property Inspector?  (Choose two.)  


A. Text  
B. Shape  
C. ActionScript 
D. Layers 


 
Correct answer: A and B  
 
3. Looking at the screenshot, considering that the circle will move from left to right, which of the 


following statements is invalid? (Choose three.) 
A. Circle will go behind square on the Stage  
B. The circle will “Shape Tween”  
C. The square will “Motion Tween”  
D. The circle will “Motion Tween” 
E. Circle will go in front of square on the Stage. 


 
Correct answer: A, B, and C  
 
4. How you can improve the readability of text in a Flash movie? 
 A. Using only “Static text”  


B. Using only “Dynamic text”  
C. Setting “Antialiasing”  
D. By increasing the font size  


 
Correct answer: C 
 
5. Which elements are important to include in a Storyboard? (Choose two.) 


A. Animation Outline to be implemented 
B. Font, size, and text color 
C. Graphical objects names used 
D. Recommended Browsers 
E. Target of every hyperlink 
F. System requirements 


 
Correct answer: A and E  
 







6. You want to test a Flash movie.  After choosing Control>Test Movie, which file(s) is(are) 
automatically generated? 
A. None; The movie is tested within Flash 
B. HTML and FLA files 
C. HTML file 
D. HTML and SWF files 
E. SWF file 
F. FLA file 


 
Correct answer: E  
 
7. Which text features can be set through the Property Inspector?  (Choose all that are true) 


A. Font 
B. Color 
C. Opacity 
D. Spacing 
E. Orientation 
F. Rotation 


 
Correct answer: A, B, D, and E  
 
8. Which of the following statements about the publication settings are true? (Choose all that are true) 


A. The settings create a publishing profile  
B. The settings cannot protect a published file 
C. They can set ActionScript versions 
D. They can specify loading order 


 
Correct answer: A, C, and D 
 
9. What is the standard unit of measurement for web pages and multimedia? 


A. Inches 
B. Centimeters  
C. Pixels 
D. Decibels  


 
Correct answer: C  
 
10. The quick key for the Selection tool is V, for the Pencil is Y, and for the Brush is B. Which is the 


fastest way to find the quick keys for the other tools? 
A. By looking in a book where they’re all listed for your reference 
B. By going to the Adobe website 
C. By rolling your cursor over the tool and waiting for the answer to appear as a ToolTip 


 
Correct answer: C  
 
11. All of the above are considerations when determining your target audience EXCEPT which one?  


A. Gender 
B. Education  
C. Age 
D. Name 


 
Correct answer: D 







 
12. Which three factors affect the playback rate? (Choose three.) 


A. Frames per second (fps) setting 
B. Number of frames in the movie 
C. User’s computer processing speed 
D. Flattens the layer 
E. Complexity of the elements in the frames 
F. Use of static text fields 


 
Correct answer: A, C, and E  
 
13. All of the above file formats can run in a web browser EXCEPT which one? 


A. WMV 
B. FLA  
C. FLV  
D. SWF  


 
Correct answer: B  
 
14. What file format enables you to edit the document timeline? 


A. WMV 
B. FLA  
C. FLV  
D. SWF  


 
Correct answer: B 
 
15. What file format is associated with a Flash video file? 
 A. WMV 


B. FLA  
C. FLV  
D. SWF  


 
Correct answer: C 
 
16. Which content is most affected by slow download speed? 
 A. Images 


B. Video 
C. Embedded fonts 
D. Style sheets 


 
Correct answer: B 
 
17. What type of graphic is defined in terms of pixel data? 


A. AI 
B. Vector  
C. Flash 
D. Bitmap  


 
Correct answer: D 
 
18. Which two methods enable you to resize a text box without resizing the text? (Choose two.) 







A. Text Menu 
B. Lasso Tool 
C. Property Inspector 
D. Subselection Tool 
E. Free Transform Tool 


 
Correct answer: B and C 
 
19. If the playhead is stopped on frame 10, which ActionScript command will cause the movie to begin 


playing at frame 20? 
A. gotoAndPlay(20) 
B. nextFrame(20) 
C. play(20) 
D. jumpToFrame(20) 


 
Correct answer: A 
 
20. Which two audio file types can be imported into Flash? (Choose two.) 


A. MP3 
B. WAV  
C. MP4 
D. M3U  


 
Correct answer: A and B 
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How to create an animated face 
This activity walks you step by step through the process of creating a simple animation by using Adobe Flash CS4. 
You use drawing tools and implement motion and shape tweens. After you test your movie, you publish it for 
playback by others, either through a browser or directly with Flash Player. 


Draw facial features 


Draw the right eye 


1. Start Flash and open a blank new document. 


2. The new document contains one layer and one empty 
keyframe. 


3. Select the Oval tool and draw a small circle to represent 
the right eye on a face (Figure 1). 


4. Select the Selection tool and double-click the circle’s 
center to select it. You should see both its outline 
(stroke) and center (fill) selected. 


5. To change the outline color of the eye, click the Stroke 
Color box in the Property inspector and select a new 
color (Figure 2). To change the fill color, use the Fill 
Color box. 


6. On the Timeline, double-click the layer name, Layer 1 
(Figure 3). 


 This selects the layer name so you can rename it. 


 
Figure 1 Right eye drawn with Oval tool 


 


 
Figure 2 Image Property inspector 


 


 
Figure 3 Layer name 


 


Oval tool 


Stroke color 


Fill color 
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7. Rename the layer Right Eye and press Enter (Windows) 
or Return (Mac OS) (Figure 4). 


 
Figure 4 New layer name 


Save the eye graphic as a symbol in the library 


Instead of creating two eyes separately, convert the right eye from a shape to a graphic symbol. This adds the eye to 
the library so you can use it over and over. This will also reduce the size of your finished movie. 


 


8. On the Right Eye layer, click frame 1 to select it 
(Figure 5). 


 This automatically selects the contents of frame 1. 


 Note: If the right eye is not completely selected, double-
click the eye on the Stage with the Selection tool to 
select it. 


9. Select Modify > Convert To Symbol. 


 The Convert To Symbol dialog box opens (Figure 6). 


10. In the dialog box, name the symbol eye, select Graphic 
as the behavior, and click OK. 


 The eye on the Stage is now just an instance (copy) of 
the master eye symbol, which is stored in the library. 
The eye now has a single blue selection border 
(Figure 7) and can be selected with a single click. 


 


 
Figure 5 Frame 1 selected 


 


 
Figure 6 Convert To Symbol dialog box 


 


 
Figure 7 Graphic symbol selected 
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11. Select Window > Library to see that your symbol has 
been added to the Library panel (Figure 8). 


 Note: You must select the eye symbol in the library to 
see the graphic in the preview window. 


 You can now reuse the eye symbol as many times as 
you want without redrawing it. 


 
Figure 8 Library panel 


Reuse the eye symbol to create the left eye 


12. Click the Insert Layer button in the lower left corner of 
the Timeline to insert a new layer (Figure 9). 


13. Double-click the layer name and change the name to 
Left Eye. 


14. On the Left Eye layer, select frame 1. 


15. Select the eye symbol in the Library panel and drag the 
symbol onto the Stage. 


 You now have a second instance of the eye on the Stage. 
Using instances from the library keeps the file size of 
your movie smaller than copying and pasting. Smaller 
movies load faster in a browser. 


 
 


Figure 9 Insert Layer button 


Draw the nose 


16. Insert a new layer and name it Nose. 


17. Select frame 1 on the Nose layer. 


18. Select the Line tool and draw two lines that form an 
angle to represent a nose (Figure 10). 


19. To adjust the angle after you’ve drawn it, use the 
Subselection tool (white arrow) to drag the corner or one 
end of the line. (You might try dragging one end of a 
line with the Arrow tool to see the difference between 
the two tools.) 


 
Figure 10 Draw nose 


Insert Layer button 
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Add frames to make a three-second movie 


A Flash movie typically plays 12 frames per second. To keep the nose on the Stage for 3 seconds, for example, you 
need to insert 36 additional frames on the Nose layer after frame 1, the current frame. (Starting at frame 1, it will 
take the movie 3 seconds to reach frame 37, because 1 + 36 = 37.) 


20. Select frame 37 on the Nose layer and select Insert > 
Timeline > Frame.  


 Flash inserts frames through frame 37 (Figure 11).  


 Observe that the playhead (the red rectangle at the top of 
the Timeline) is on frame 37 and that the nose is visible 
but the eyes have disappeared. At the bottom of the 
Timeline, you can see that this movie is currently 37 
frames, is set to play at 12 frames per second, and will 
play for 3 seconds. 


 Note: The keyboard shortcut for inserting a frame is F5.  


21. Drag the playhead to various frames. 


 The nose remains visible in frames 1 through 37, but the 
eyes appear only in frame 1. 


22. To see your movie, drag the playhead to frame 1 and 
then select Control > Play. 


 At this point, not much is happening beyond frame 1. 


 
Figure 11 Frame inserted in Timeline 


Draw the mouth 


23. Insert a new layer and name it Mouth. 


24. Select frame 1 of the Mouth layer. 


25. Draw a mouth in frame 1. 


• Use the Line tool to draw a straight line 
(Figure 12).  


• Select the Selection tool and click on the Stage 
away from the line to deselect it.  


• Move the pointer toward the middle of the line. 
When a curve appears next to the pointer, drag the 
middle of the line downward to create a smile 
(Figure 13).  


• When you release the mouse button, only the smile 
remains (Figure 14). 


 
Figure 12 Mouth as straight line 


 


 
Figure 13 Drag line with Arrow tool 
 


 
Figure 14 Mouth complete 
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Animate the facial features 


Use motion tweens to animate the eyes 


Because you created the eyes by using a graphic symbol, you can animate them by using a motion tween. To create 
the motion tween, you need to extend the Timeline in the Right Eye layer. 


1. On the Right Eye layer, select frame 37 and select 
Insert > Timeline > Frame (Figure 15).  


2. With the Right Eye layer selected, choose Insert > 
Motion Tween. 


3. Select frame 37 on the Right Eye layer and drag the 
right eye a short distance.  


 A motion path appears on the Stage showing the path 
from the position in the first frame of the tween span to 
the new position (Figure 16). Because you explicitly 
defined the X and Y properties of the object, property 
keyframes are added for X and Y in the frame 
containing the playhead. Property keyframes appear as 
small diamonds in the tween span on the timeline. 


4. Position the playhead on frame 1 and select 
Control > Play to play your movie and see the effect of 
the motion tween. 


 The right eye gradually moves from its original position 
in frame 1 to the new position in frame 37. Notice that 
only the right eye moves. 


 Note: If you want to change the motion, move only the 
symbol in keyframe 37. 


5. Choose frame 37 on the Left Eye layer and select 
Insert > Timeline > Frame.  


6. With the Right Eye layer selected, choose Insert > 
Motion Tween. In frame 37 move the left eye the same 
distance as the right eye. 


 
Figure 15 Tween span in the Timeline panel 


 


 
Figure 16 Tweened object with a motion path 
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Use a shape tween to animate the mouth 


Because you created the mouth by using one of the drawing tools (the Line tool) and have not converted the mouth 
to a symbol, it is still a shape. You can use a shape tween to animate the mouth. 


1. Select frame 37 on the Mouth layer and insert a 
keyframe. 


2. With the Selection tool, click on the Stage away from 
the mouth line to deselect it. Then drag the mouth line 
into a bigger smile. 


3. To create a shape tween between the first and last 
frames on the Mouth layer, click a frame between 
frames 1 and 37, and select Insert > Shape Tween. 


 The frames containing the shape tween are now light 
green and contain a solid arrow running from the start 
frame to the end frame (Figure 17).  


4. Select File > Save. 


5. Select Control > Test Movie to see it play. 


 Selecting Control > Test Movie exports a .swf file and 
plays it in a preview window. When the movie reaches 
the last frame, it loops back to frame 1 and plays again. 


6. Select File > Close to close the preview window. 


 
Figure 17 Shape Tween on the Mouth layer 


Create any additional animated facial features as you choose. 
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Publish your movie 
When you’re ready to deliver your movie to an audience, you can publish the Flash document (FLA file) for 
playback. The Publish command creates a Flash SWF file (playable with Flash Player) and an HTML document that 
inserts your Flash movie in a browser window. For viewers who do not have Flash Player installed, you can select to 
publish the FLA file in alternative file formats—GIF, JPEG, PNG, or QuickTime—with the HTML needed to 
display them in a browser window. 


When you publish HTML with your movie, Flash also creates a file called AC_OETags.js. This JavaScript file lets 
your SWF file play automatically in certain browsers (called active content-compliant browsers) that would 
otherwise require a site visitor to click to play your movie. To avoid this problem, upload AC_OETags.js to your 
site in the same location as the HTML file that hosts the movie. For more about this issue, visit 
www.adobe.com/go/activecontent. 


1. Select File > Publish Settings to open the Publish 
Settings dialog box (Figure 18). 


2. Use the Formats tab to determine which file formats to 
output when you publish. 


 


 
Figure 18 Publish Settings dialog box 



http://www.adobe.com/go/activecontent�
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3. Use the Flash tab to determine which Flash Player you 
are publishing to (Figure 19). If you think your 
audience might not have the latest player, you might 
want to select an older player from the Version menu. 


4. Select Generate Size Report to see a detailed report of 
size for each asset in your movie. 


5. Select Protect From Import to prevent anyone from 
importing your SWF file into Flash and converting it 
back to a FLA file. 


6. Select Compress Movie to reduce the file size of the 
exported movie. 


7. Use the HTML tab to control settings for the HTML file 
(Figure 20). 


8. Deselect the Loop option if you want your movie to play 
through only one time and stop. 


9. To publish your movie, click the Publish button. 


 
Figure 19 Flash tab of Publish Settings dialog box 


 


 
Figure 20 HTML tab of Publish Settings dialog 
box 
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How to get started with ActionScript 
ActionScript 3.0 is the scripting language of Adobe Flash CS4. You can use ActionScript to add complex 
interactivity, playback control, and data display to your application. For example, you might want to animate a 
picture of a boy walking. By adding ActionScript, you could have the animated boy follow the pointer around the 
screen, stopping whenever he collides with a piece of animated furniture. 


ActionScript is an object-oriented programming language. Object-oriented programming is a way to organize the 
code in a program, using code to define objects and then sending messages back and forth between those objects. 


You don’t have to be a programmer to take advantage of ActionScript (see “Using Script Assist mode” later in this 
guide). But the following concepts will help: 


• Class: The code that defines an object. This code consists of properties, methods, and events. Think of the 
blueprint of a house: you can’t live in the blueprint, but you need it so you can build the house. You use 
classes to create objects. 


• Object: An instance of a class. When you instantiate an object (create an instance of it), you declare what 
class it is created from and set its properties. You can create as many objects as you want from a single 
class—if you have a bicycle


• Property: One of the pieces of data bundled together in an object. A property helps define an object—it 
provides the object’s characteristics. A song object might have properties named 


 class, you can create many bicycle objects, each with its own properties 
(one bicycle might be red while another might be green). 


melody and title


• Variable: 


. 
You set the properties of an object when you create the object, but you can change them later as needed. A 
property is a variable that belongs to an object. 


A name that represents a value in the computer’s memory. As you write code, you write the 
variable’s name as a placeholder for the value. This allows you to write code even if you don’t know all the 
possible values a visitor might provide. If you create a variable firstName


• Method: An action that can be performed by an object. For example, the class 


, you can tell your program to 
display the visitor’s first name without knowing in advance what the visitor’s first name is. 


horse might have a method 
called gallop(). When the method gallop()


• Function: A block of code that carries out specific tasks and can be reused in your program. For example, 
you might create a function called 


 is called, it shows an animation of the horse galloping 
from one point to another. 


checkEmail() to verify that text typed by a visitor is a valid e-mail 
address. Each time a visitor provides an e-mail address, you can call checkEmail()


• Event: Something that happens in a Flash movie that ActionScript is aware of and can respond to. Many 
events are related to user interaction—for example, a user clicking a button or pressing a key on the 
keyboard. The technique for specifying certain actions that should be performed in response to particular 
events is known as event handling. 


 to make sure the 
visitor has provided text that can actually be used as an e-mail address. If you ever want to update the 
function, you only have to do it once instead of in each place where e-mail addresses must be validated. 
You can also think of a method as a function attached to an object. 


If you’ve worked with symbols in Flash, you’re already used to working with objects. Imagine you’ve defined a 
movie clip symbol—say a drawing of a rectangle—and you’ve placed a copy of it on the Stage. That movie clip 
symbol is also an object in ActionScript; it’s an instance of the MovieClip class. The main timeline of a Flash movie 
also belongs to the Movie Clip class. 


You can modify various characteristics of any movie clip. When a movie clip is selected, the Property inspector 
shows some of the characteristics you can change, such as its X coordinate or its width. Or you can make color 
adjustments such as changing the clip’s alpha (transparency). Other Flash tools let you make more changes, such as 
using the Free Transform tool to rotate the rectangle. All of the ways you can modify a movie clip symbol in the 
Flash authoring environment are also things you can do in ActionScript. In ActionScript, you use the methods of the 
MovieClip class to manipulate or change the properties of your movie clip. 
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For more about object-oriented programming, see Programming ActionScript 3.0, “Object-oriented Programming in 
ActionScript” (in Flash, select Help > Flash Help). 


Using Script Assist mode 
You can add ActionScript in the authoring environment by using the Actions panel (Figure 1). The Actions panel 
provides Script Assist mode to simplify the coding process. 


 
Figure 1 Actions panel in Script Assist mode 


In Script Assist mode, you can add ActionScript to your Flash document without writing the code yourself. You 
select actions from the Actions toolbox and set the options for each action in the parameters area. You must know a 
little about what functions to use to accomplish specific tasks, but you don’t have to learn syntax (the grammar of 
ActionScript). Many designers and nonprogrammers use this mode. 


One of the first things to learn is how to stop your movie at a certain spot. You will also learn how to send the 
playhead to a particular frame in the movie. 


Parameters area 


Actions toolbox 


Script navigator 


Script pane 


Script Assist button 
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Using ActionScript to stop a movie 


1. Start Flash and open a movie. Create a layer in your 
movie named actions. In the frame that corresponds to 
the end of your movie, insert a new keyframe. 


2. Select Window > Actions to display the Actions panel. 


3. If you don’t see the parameters area in the Actions 
panel, click the Script Assist button in the upper-right 
corner (Figure 2). 


 Classes are organized into packages. You want to add a 
stop() action to a movie clip (in this case, your 
timeline is the movie clip), so you must locate the 
Movie Clip class. The Movie Clip class is part of the 
Flash.Display package. 


4. In the Actions toolbox on the left side of the Actions 
panel, scroll down and click the Flash.Display package 
to display the classes it contains. 


5. Scroll down again to find the Movie Clip class and click 
to expand it (Figure 3). 


6. Click Methods to view the methods available for the 
Movie Clip class. 


 


 
Figure 2 Actions panel 


 


 
Figure 3 Movie Clip class 


 


Script Assist button 
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7. Scroll down to the Stop method. Do one of the 
following:  


• Double-click the Stop method. 


• Drag the Stop method into the Script pane. 


 Code for applying the Stop method appears in the Script 
pane (Figure 4). The first line (import 
flash.display.MovieClip();) imports the 
code necessary for the Movie Clip class. The second line 
is the Stop action itself. The red code not_set_yet 
indicates you should use Script Assist to finish the code. 


8. Click in the Object field in the parameters area of the 
Actions panel. 


 The Insert Target Path button is now active. The target 
path helps you locate the object you are trying to 
control. 


9. Click the Insert Target Path button. 


 The Insert Target Path dialog box appears (Figure 5). 


10. Select the Relative option and click Root. 


 This sets the target path to this. 


11. Click OK to close the Insert Target Path dialog box. 


 The completed script for the Stop method appears in the 
Script pane (Figure 6). This code will cause your movie 
to stop playing at the end of the movie, frame 40. 


 Note: In ActionScript, this is used the same way that 
you would refer to yourself as “me” instead of using 
your full name. Remember that the main timeline is an 
instance of the MovieClip class. In Figure 6, Flash uses 
this


 


 to refer to the movie clip that frame 40 belongs to. 


12. Close the Actions panel. 


 
Figure 4 Stop method 


 


 
Figure 5 Insert Target Path dialog box 


 


 
Figure 6 Stop method applied to frame 40 


 


Frame number 


Insert Target Path button 
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Event handling 
The technique for specifying certain actions that should be performed in response to particular events is known as 
event handling. Event handling consists of three important elements: 


• The event source: Which object will trigger the event? For example, which button will be clicked, or which 
Loader object is loading the image? 


• The event: What is going to happen, what interaction do you want to respond to? Identifying the event is 
important, because an object can trigger (and listen for) several events. 


• The response: What action(s) do you want performed when the event happens? 


When an ActionScript program is running, Adobe Flash Player just sits and waits for certain events to happen, and 
when those events happen, the player runs the specific ActionScript code you’ve specified for those events. For the 
program to know what events are important, you must create an event listener. An event listener is a function Flash 
Player executes in response to specific events. 


Adding an event listener is a two-step process: 


• First, you create a function or class method for Flash Player to execute in response to the event. This 
function is sometimes called the listener function. 


• Second, you use the addEventListener() method to connect the listener function with the target of the event. 
The addEventListener() function tells Flash what object to listen to, what event to listen for, and what 
function to execute in response. 


Using ActionScript to go to another frame 


1. Create a button users can click to go to a particular 
frame in your movie. Make sure you place the button on 
the Stage (Figure 7). 


2. Select the button and use the Property inspector to give 
the button a unique instance name (Figure 8). 


3. In the main timeline of your movie, create a layer named 
actions. 


4. Create a keyframe in the actions layer that corresponds 
to the keyframe where your button first appears on the 
Stage. Select this keyframe in the actions layer. 


 Note: If your button doesn’t appear in this frame, Flash 
will generate an error message because you are referring 
to an object that isn’t on the Stage yet. 


5. Select Window > Actions to display the Actions panel. 


6. If you don’t see the parameters area in the Actions 
panel, click the Script Assist button. 


7. In the Actions toolbox on the left side of the panel, 
select the AddEventListener method from the 
IEventDispatcher class. 


 To find the AddEventListener method, open 
flash.events, and then open IEventDispatcher. 


 
Figure 7 Button instance 


 


 


 
Figure 8 Button instance 


 


 


Instance name 
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8. Double-click the AddEventListener method to add it to 
the Script pane (Figure 9). 


9. Click in the Object field in the parameters area of the 
Actions panel. 


 The Insert Target Path button is now active. 


10. Click the Insert Target Path button. 


 The Insert Target Path dialog box appears (Figure 10). 


11. Select the Relative option and select the instance name 
of your button. Click OK to close the dialog box. 


 The event listener is attached to the instance of your 
button (Figure 11).  


 Next, you select an event to listen for. 


 
Figure 9 AddEventListener method in the Actions 
toolbox 


 


 
Figure 10 Insert Target Path dialog box 


 


 
Figure 11 Event listener code in the Script pane 
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12. In the Actions toolbox on the left side of the panel, 
select the CLICK property from the MouseEvent class 
(Figure 12). 


 To find the CLICK property, open Flash.Events, open 
MouseEvent, and open Properties. 


13. In the Script pane, select the AddEventListener() line to 
display the parameters for this method. Then, in the 
parameters area, click in the Type field. 


14. In the Actions toolbox, double-click the CLICK 
property. 


 Script Assist adds the property to your code as 
MouseEvent.CLICK


 Now your code will listen for a click on the button. To 
tell the event listener how to respond when that click 
occurs, you next create a function. 


 (Figure 13). 


15. In the parameters area, type a name for your function in 
the Listener field. You can use any name you like, but 
make sure the name of the function is unique and 
contains no spaces (Figure 14). 


 The function name appears in the Script pane as you 
type. You have named the function, but you haven’t 
created it yet. 


16. In the Actions toolbox, select the function


 To find the 


 keyword 
from Language Elements. 


function


17. Double-click the function keyword in the Actions 
toolbox. 


 keyword, expand Language 
Elements. Then expand Statements, Keywords & 
Directives, and expand Definition Keyword. 


 The code for creating a function appears in the Script 
pane (Figure 15). 


18. In the parameters area of the Script pane, type the name 
of your function in the Name field. 


 Note: The function name must be typed exactly as you 
typed it for the AddEventListener function in step 15. 
Function names are case-sensitive. 


19. In the parameters area of the Script pane, type 
event:MouseEvent in the Parameters field. 


 In this field, you are naming a variable (event) and 
indicating what type of variable it is (MouseEvent). 


 
Figure 12 CLICK property in the Actions toolbox 


 


 
Figure 13 CLICK property in the Script pane 


 


 
Figure 14 Function name in the Listener field 


 


 
Figure 15 Function code 
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20. In the parameters area of the Script pane, select Void 
from the Type pop-up menu. 


 Some functions return a value when called. The 
keyword void


 Now you can tell the function what you want it to do 
when the CLICK event occurs. 


 indicates that this function does not 
return a value. 


21. In the Actions toolbox on the left side of the panel, 
select the GotoAndPlay method for the Flash.Display 
class (Figure 16). 


 To find the GotoAndPlay method, expand 
Flash.Display, and then expand MovieClip. 


22. Select the function in the Script pane and double-click 
the GotoAndPlay method in the Actions toolbox. 


 The method is added to the function (Figure 17). 


23. Click in the Object field in the parameters area of the 
Actions Panel. 


 The Insert Target Path button is now active. 


24. Click the Insert Target Path button to display the Insert 
Target Path dialog box. 


25. Select the Relative option and select the movie clip you 
want to play when the button is clicked. If you want the 
movie in the main timeline to play, select Root to set the 
target path to this


26. Click OK to close the Insert Target Path dialog box. 


. 


27. In the Frame field, type the number of the frame you 
want to send the playhead to. For example, if you want 
the movie to start from the beginning, type the number 1 
to play the movie’s first frame. 


28. Close the Actions panel. 


29. Save the movie. 


30. Select Control > Test Movie to test the movie. 


31. Select File > Close to close the preview window. 


 
Figure 16 GotoAndPlay method 


 


 
Figure 17 GotoAndPlay method in the Script pane 


 


For more about ActionScript, see Programming ActionScript 3.0, “Getting Started with ActionScript” (in Flash, 
select Help > Flash Help). 


 







Adobe Flash CS4 Activity 5.1 guide 


© 2008 Adobe Systems Incorporated How to create a button symbol 1 


How to create a button symbol 


Button symbols 
Buttons give visitors a way to control parts of a movie. You can use button symbols to create interactive buttons that 
respond to mouse clicks, rollovers, or other visitor interaction. Button symbols are four-frame interactive movie 
clips. The first three frames display the button’s three possible states: Up, Over, and Down. The fourth frame, Hit, 
defines the active area of the button. The Timeline for a button doesn’t play like other movies; it reacts to pointer 
movement and actions by jumping to and displaying the appropriate frame. 


You can create the image that represents your buttons in several ways. For example, you can use an existing graphic 
as the button, or you can create a shape by using the drawing tools. 


Create a button 
You will create a new button symbol that contains two layers. One layer will contain a shape representing the 
background of the button. The second layer will include a text label for the button. You will change the background 
and text label in the Over and Down states of the button to create the rollover effect. 


1. Start Adobe Flash CS4 and create a new Flash file 
(ActionScript 3.0). 


2. Select Insert > New Symbol. 


 The Create New Symbol dialog box appears (Figure 1). 


3. Select Button as the behavior type, name the button, and 
click OK. 


 You are now in symbol-editing mode and viewing a 
separate Timeline for the button symbol. The Up frame 
contains a keyframe (Figure 2). 


 Each frame on the Timeline of a button symbol has a 
specific function: 


• Up state: Represents the button’s appearance 
whenever the pointer is not over the button. 


• Over state: Represents the button’s appearance 
when the pointer is over it. 


• Down state: Represents the button’s appearance as 
it is clicked. 


• Hit state: Defines the area that will respond to a 
mouse click. This area will be invisible in the 
published movie. 


4. Make sure the Up frame is selected. 


5. Use the drawing tools to create a shape for your button. 
Use the Property inspector to set the fill and stroke 
colors for the Up state of the button. 


6. Select the Over state and select Insert > Timeline > 
Keyframe to add a keyframe. 


 Adding this keyframe copies the button graphic from the 
Up frame to the Over frame. 


 
Figure 1 Create New Symbol dialog box 


 


 
Figure 2 Button frames: Up, Over, Down, Hit 
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7. Select the Over keyframe and use the Selection tool to 
select the button. 


8. Change the fill or stroke color of the button shape. 


 When visitors roll over the button, the button will appear 
as you see it in the Over frame. 


9. Insert keyframes in the Down and Hit frames of the Text 
layer. 


 This copies the button graphic from the Over frame to 
the Down and Hit frames. 


10. Insert a new layer and name it Text. 


11. Select the Up frame of the Text layer. 


 This frame already contains a keyframe. 


12. Use the Text tool to type text on the button shape. 


13. Use the Property inspector to adjust the font, size, and 
color of the text so it fits nicely on your button shape. 


14. Use the Selection tool or the Up, Down, Left, and Right 
Arrow keys to position the text on the button shape. 


15. Insert a keyframe in the Over frame of the Text layer. 


16. Select the text and use the Property inspector to change 
some feature of the text in the Over frame, such as color. 


17. Insert a keyframe in the Down frame. If you want the 
text to change appearance when the button is clicked, 
edit the appearance of the text in the Down frame. 


 The Timeline should now appear as it does in Figure 3. 


 Now you can insert an instance (copy) of the button 
symbol into the main Timeline of your movie. 


18. Click Scene 1 to exit symbol-editing mode and return to 
the main Timeline. 


19. Select Window > Library to display the Library panel. 


 The new button symbol appears in the Library panel 
(Figure 4). 


 Note: You must select the symbol in the library to see 
the symbol in the preview pane. 


20. Drag the button symbol from the library onto the Stage. 


21. Select Control > Test Movie to test the movie. 


 When you roll over the button with the pointer, you see 
the changes you defined in the Over frames for the 
button. If you edited the Down state of the button, this 
will be visible when you click the button. 


22. Select File > Close to close the preview window. Then 
save your movie. 


 
Figure 3 Button Timeline 


 


 
Figure 4 Button in library 
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Adding sound to a button 


You can also add sounds to the button so visitors hear a sound when they interact with the button. 


1. Use the Selection tool to double-click the button to enter 
symbol-editing mode for the button. 


2. Insert a new layer and name it Sound. 


3. Select File > Import > Import To Library to import a 
short sound into the library.  


 You can acquire royalty-free sounds from sites such as 
www.flashkit.com. 


4. On the Sound layer, add a keyframe to correspond with 
the button state to which you want to add a sound. 


 For example, to play a sound when visitors roll over the 
button, add the keyframe to the Over state. 


5. Click the new keyframe. 


6. Make sure the Property inspector is visible. (Select 
Window > Properties.) 


7. In the Property inspector, select a sound file from the 
Sound pop-up menu (Figure 5). 


8. Select Event in the Sync pop-up menu. 


 The sound will play when visitors interact with the 
button. 


 
 


Figure 5 Property inspector 


 


Sound pop-up menu 



http://www.flashkit.com/�
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Adding control with actions 


Right now the button looks great, but it doesn’t perform any action. You can remedy this by adding ActionScript 
code to your movie. 


Buttons give visitors control over the movie. You can create code for your buttons to stop the movie, stop sounds, 
restart the movie (after stopping it), or jump to different frames within the movie and begin playing. You can add 
actions to any instance of the button symbol you’ve placed in your movie. 


1. Select the button instance to which you want to add an 
action. Use the Name text box in the Property inspector 
to give the button a unique instance name (Figure 6). 


2. In the main timeline of your movie, create a new layer 
named Actions. 


3. Create a keyframe in the actions layer that corresponds 
to the keyframe where your button first appears on the 
Stage. Select this keyframe in the actions layer. 


 Note: If your button doesn’t appear on this frame, Flash 
generates an error message when you publish the movie 
because the ActionScript you include on this frame 
refers to an object that isn’t on the Stage yet. 


4. Select Window > Actions to display the Actions panel. 


5. If you don’t see the parameters area in the Actions 
panel, click the Script Assist button. 


6. In the Actions toolbox on the left side of the panel, 
select the AddEventListener method for the 
IEventDispatcher class. 


 To find the AddEventListener method, expand 
Flash.Events, and then expand IEventDispatcher. 


7. Double-click the AddEventListener method to add it to 
the Script pane (Figure 7). 


8. Click in the Object field in the parameters area of the 
Actions panel. 


 The Insert Target Path button is now active. 


9. Click the Insert Target Path button. 


 The Insert Target Path dialog box appears (Figure 8). 


10. Select the Relative option and select the instance name 
of your button. Click OK to close the dialog box. 


 
 


Figure 6 Button Property inspector 


 


 
Figure 7 AddEventListener method in the Actions 
toolbox 


 


 
Figure 8 Insert Target Path dialog box 


Instance name 
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11. In the Actions toolbox on the left side of the panel, 
select the CLICK property from the MouseEvent class 
(Figure 9). 


 To find the CLICK property, expand Flash.Events, and 
then expand MouseEvent. 


12. In the Script pane, select the AddEventListener() line to 
display the parameters for this method. Then, in the 
parameters area, click in the Type field. 


13. In the Actions toolbox, double-click the CLICK 
property. 


 Script Assist adds the property to your code as 
MouseEvent.CLICK (Figure 10). 


14. In the Listener field in the parameters area, type a name 
for the function that should execute when the button is 
clicked. You can use any name you like, but make sure 
the name of the function is unique and contains no 
spaces. 


 The function name appears in the Script pane as you 
type. You have named the function, but you haven’t 
created it yet. 


15. In the Actions toolbox, select the function keyword 
from Language Elements.  


 To find the function keyword, expand Language 
Elements. Then expand Statements, Keywords & 
Directives, and expand Definition Keyword. 


16. Double-click the function keyword in the Actions 
toolbox. 


 The code for creating a function appears in the Script 
pane. 


17. In the parameters area of the Script pane, type the name 
of your function in the Name field. 


 Note: You must type the function name exactly as you 
typed it for the AddEventListener function. Function 
names are case-sensitive. 


18. In the parameters area of the Script pane, type 
event:MouseEvent in the Parameters field (Figure 11). 


 In this field, you are naming a variable (event) and 
indicating what type of variable it is (MouseEvent). 


19. In the Actions toolbox on the left side of the panel, 
select the StopAll method for the SoundMixer class. 


 To find the StopAll method, expand Flash.Media, and 
then expand SoundMixer. 


 
Figure 9 CLICK property in the Actions toolbox 


 


 
Figure 10 CLICK property in the Script pane 


 


 
Figure 11 Function code in the Script pane 
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20. Select the function in the Script pane and double-click 
the StopAll method in the Actions toolbox. 


 The method is added to the function (Figure 12). 


21. Save the movie. 


 Now when visitors click the button, all sounds currently 
playing in the movie will stop. 


  
Figure 12 StopAll method in the Actions panel 


For more about ActionScript, see Programming ActionScript 3.0, “Getting Started with ActionScript” (in Flash, 
select Help > Flash Help). 
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How to create text effects with filters 
You can add graphics filters to text, movie clips, and buttons in Adobe Flash CS4. Graphics filters are available in 
the Filters section of the Property inspector. 


Applying the Drop Shadow filter to text 
The Drop Shadow filter makes it appear that text or an object is casting a shadow. 


1. Start Flash and open the document you want to edit. 


2. Select the text to which you want to add a filter. 


3. In the Property inspector, display the Filters section 
(Figure 1). 


 If the Property inspector isn’t visible, select Window > 
Properties. 


4. Click the Add Filter icon ( ) in the lower left corner of 
the panel. 


5. Select Drop Shadow in the Filters menu (Figure 2). 


 The Drop Shadow filter is applied to the text (Figure 3). 


 
 


Add Filter icon 


Figure 1 Filters section of the Property inspector 


 


 
Figure 2 Filters menu 


 


 
Figure 3 Drop shadow applied 
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 You can adjust the characteristics of the Drop Shadow, 
such as its color, in the Filters section of the Property 
inspector (Figure 4). 


 
Figure 4 Drop shadow properties 


Other graphics filters 
There are several other graphics filters that you can apply to text to create interesting visual effects. 


Blur 


The Blur filter softens the edges and details of objects. Applying a blur to an object can make it appear as if it is 
behind other objects, or make an object appear to be in motion.  Adjust the amount and direction of blur by using the 
X and Y text boxes. 


Glow 


The Glow filter lets you apply a color around the edges of an object. 


• Glow: Make the object appear to shine. 


• Inner Glow: Apply the glow only within the boundaries of the object. 


• Knockout: Remove the object and leave the glow. The object appears outlined in glow. 


Bevel 


Applying a bevel applies a highlight to the object that makes it appear to be curved up above the background 
surface. 


• Inner Bevel: Give the object a three-dimensional look by applying highlights and a shadow to the inside of the 
object. 


• Outer Bevel: Give the object a three-dimensional look by applying highlights and a shadow to the outside of the 
object. 


• Full Bevel: Apply both inner bevel and outer bevel effects to the object. 


You can alter the bevel’s shadow and highlight colors, the type of bevel (inner, outer, or full), its strength, and the 
angle of light that falls on it. 







Adobe Flash CS4 Activity 6.1 guide 


© 2008 Adobe Systems Incorporated How to create text effects with filters 3 


Gradient Glow 


Applying a gradient glow produces a glow look with a gradient color across the surface of the glow. The gradient 
glow requires one color at the beginning of the gradient with an Alpha value of 0. You cannot move the position of 
this color, but you can change the color. 


Gradient Bevel 


Applying a gradient bevel produces a raised look that makes an object appear to be raised above the background, 
with a gradient color across the surface of the bevel. The gradient bevel requires one color in the middle of the 
gradient with an alpha value of 0. 


Adjust color 


The Adjust Color filter allows you to finely control the color attributes of the selected object, including contrast, 
brightness, saturation, and hue. 


• Brightness: Make the object brighter or darker. 


• Contrast: Increase or decrease the distinction between light and dark. 


• Saturation: Increase the intensity of color. For example, raising saturation on blue text makes the text a more 
vibrant blue. 


• Hue: Increase or decrease the shade of the color. 







Adobe Flash CS4 Activity 6.1 guide 


© 2008 Adobe Systems Incorporated How to create transitions with motion tweens 1 


How to create transitions with motion tweens 
You may have noticed from watching television or movies that transitions are a subtle but important part of telling a 
story. For example, dissolving between images can indicate a passage of time. On the web, you can use transition 
effects to create moods and to help keep your visitors interested. You can use transitions to focus the visitor’s 
attention or to indicate a preferred path through your site. One way to create transitions in Adobe Flash CS4 is to 
apply effects to a motion tween. 


Rotation 
In the Property inspector, you can add rotation to any motion tween. Rotation can draw attention to content that is 
entering or exiting the Stage. 


To add rotation to a motion tween: 


1. Open an existing Flash document or create and save a 
new Flash document. 


2. Add a symbol to the Stage and make sure it is alone on 
its own layer. By default the symbol is placed in the first 
keyframe of the timeline. This will be the first frame and 
starting symbol position for the motion tween. 


3. Decide how much time is required for the symbol to 
move to or from the Stage. 


 This tells you where to place the ending frame for the 
motion tween. 


4. Insert the ending frame accordingly on the Timeline 
(Figure 1). 


 Note: If you are calculating in seconds, be sure to note 
the frame rate (fps) at the bottom of the Timeline. By 
default, Flash sets new documents to 12 frames per 
second. 


5. Select the layer in the Timeline and select Insert > 
Motion Tween. 


6. In the last keyframe, use the Selection tool to move the 
object to its ending position (Figure 2). Notice the 
appearance of the motion path. 


 Note: You might want to add multiple effects, such as 
changing size or fading to make the object appear to 
grow or fade in while it enters or fade out and shrink as 
it exits. 


• Changing size: Reduce or increase the image 
percentage in the Transform panel with the 
Constrain options selected. 


• Fading: Select the symbol and select Alpha from 
the Style menu in the Color Effect section of the 
Property inspector. Adjust the alpha setting to 
increase or decrease transparency. 


 
Figure 1 Flash Timeline 


 


 
Figure 2 Motion tween end position 
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7. With the tween layer selected, display the Rotation 
section of the Property inspector. Select CW (clockwise) 
or CCW (counterclockwise) from the Direction pop-up 
menu (Figure 3). 


8. For Rotate, enter the number of times you want the 
symbol to rotate (Figure 4). 


9. In the Options section, select the Sync Graphic Symbols 
option. 


 This synchronizes the motion to the number of frames in 
the Timeline. 


10. Save the movie. 


11. Select Control > Test Movie to test the movie. 


12. Select File > Close to close the preview window. 
 


Figure 3 Direction menu in the Rotation section 


 


 
Figure 4 Rotate parameter 


Change frame rate 


The document’s frame rate determines how fast the playhead moves. By default, frame rate is set at 12 frames per 
second (fps), which usually gives the best results on the web. You can change this to any number between 0.01 
and 120. QuickTime and AVI movies generally have a frame rate of 12 fps, while the standard motion picture rate is 
24 fps. Performance of a Flash movie is likely to suffer at frame rates of 16 fps or higher. With larger movies, 
increasing the frame rate increases the size of your published document. 


In short, if you want to change the timing of an animation, it’s usually better to change the number of frames than to 
change the frame rate. 
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To change the frame rate: 


1. Select Edit > Deselect All to make sure no objects are 
selected. 


 The Property inspector switches to Document. 


2. For FPS (in the Properties section), type 15 and press 
Enter (Windows) or Return (Mac OS). 


 Note: It is generally best to keep frame rate to 16 or less.  


3. Select Control > Test Movie to test the movie. 


 Observe that the animation plays faster. 


4. Change the FPS value to 6 and press Enter (Windows) 
or Return (Mac OS). 


5. Select Control > Test Movie to test the movie. 


 Observe that the animation plays much more slowly. 


6. Select File > Close to close the preview window. 


 


Fading 
By creating a motion tween with different alpha settings, you can fade images in and out. 


To fade images in and out: 


1. Start Flash and open the document you want to edit. 


2. Locate the layer and keyframe that contain the symbol 
you plan to fade.  


 This will be the starting frame for the fade. 


3. Make sure the symbol is alone on its own layer. 


4. Decide how much time is required for the symbol to 
complete the transition.  


 This tells you where to place the ending frame for the 
motion tween. 


5. Insert the ending frame accordingly on the Timeline. 
Then, with the layer selected, select Insert > 
Motion Tween. 


 Note: If you are calculating in seconds, be sure to note 
the frame rate (fps) at the bottom of the Timeline. By 
default, Flash sets new movies to 12 frames per second. 


6. Select the starting frame for the transition and click on 
the symbol to select it. 


7. Display the Motion Editor by clicking the Motion Editor 
tab next to the Timeline tab (Figure 5). Or select 
Window > Motion Editor. 


 


 
Figure 5 Timeline and Motion Editor tabs 
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 Note: The Motion Editor displays all tween properties 
and their property keyframes. It also provides tools for 
adding precision and detail to tweens. The Motion 
Editor displays the properties of the currently selected 
tween. 


8. In the Motion Editor, click the plus icon and select 
Alpha in the Color Effect tab (Figure 6). 


9. Adjust the Alpha slider down to 0% (Figure 7). 


 Note: The object will disappear from the Stage, but the 
blue outline is visible when the symbol is selected. 


10. Return to the Timeline and select the final frame and 
adjust the Alpha of the symbol to 100% using the 
Motion Editor. 


11. Save the movie. 


12. Select Control > Test Movie to test the movie. 


 The symbol fades in. 


 Note: To create a fade-out, leave the Alpha Amount 
setting at 100% on the starting keyframe and change the 
Alpha Amount setting on the ending keyframe to 0%. 


13. Select File > Close to close the preview window. 


 
Figure 6 Motion Editor Alpha controls 


 


 
Figure 7 Alpha Amount slider 
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Color fades 
You can use color fades to draw the viewer’s attention to an object onscreen. To create a color fade, apply a motion 
tween between two instances of the same symbol, and then change the color of the instances in the starting and 
ending frames. 


To create a color fade: 


1. Start Flash and open the document you want to edit. 


2. Locate the layer and keyframe that contain the symbol. 


 This will be the starting keyframe for the color fade. 


3. Make sure the symbol is alone on its own layer. 


4. Decide how much time is required for the symbol to 
complete the transition. 


 This tells you where to place the ending frame for the 
motion tween. 


5. Insert the ending frame accordingly in the Timeline. 
Select the layer in the Timeline and choose Insert > 
Motion Tween. 


 Note: If you are calculating in seconds, be sure to note 
the frame rate (fps) at the bottom of the Timeline. By 
default, Flash sets new movies to 12 frames per second. 


6. Select the starting frame for the transition and select the 
symbol. 


7. In the Motion Editor, click the plus icon and select 
Adjust Color in the Filters tab (Figure 8).   


8. Use the Hue slider to select a new color by changing the 
value.  (Figure 9). 


 As you change the value, notice the changing color of 
the symbol on the Stage. 


9.  When you have selected a color, save the movie. 


10. Select Control > Test Movie to test the movie. 


11. Select File > Close to close the preview window. 


 
Figure 8 Adjust Color in the Filters section 


 


 
Figure 9 Hue slider 


 


 







Activity 6.1 guide Adobe Flash CS4 


6 How to create transitions with motion tweens © 2008 Adobe Systems Incorporated 


Flipping images 
Flipping images and then creating a motion tween can create an effective transition between images of roughly the 
same size. The trick is to flip the first image half way and then start fading in the second image while the first image 
is still flipping to make a smooth transition. 


To flip an image: 


1. Start Flash and open the document you want to edit. 


2. Locate two image symbols on different layers that you 
plan to transition between: the entering object and the 
exiting object (Figure 10). Position the symbols in 
roughly the same position on the Stage  


3. Decide how much time is required to complete the 
transition.  


 This tells you where to place the ending frames for each 
of the images for the motion tweens. 


4. Insert the ending frames accordingly in the Timeline. 
For each image, select the layer in the Timeline and 
choose Insert > Motion Tween. 


5. Select the first motion tween in the first layer. In the 
Motion Editor, choose the Alpha color effect and set the 
image to 0% (Figure 11). 


6. Select the second motion tween in the second layer and 
change the Alpha color effect of this image to 100%. 


7. Click on the last frame for the first image in the 
Timeline and set the Alpha color to 100%. 


8. Click on the last frame for the second image in the 
Timeline and set the Alpha color to 0%. 


9. In the middle of the Timeline, select the exiting object 
on the Stage and select Modify > Transform > 
Flip Horizontal (Figure 12). 


 Note: Instead of Flip Horizontal, you can select Flip 
Vertical. As long as both exiting and entering objects 
flip the same way, the transition will work. Select the 
same type of flip for the entering object as for the 
exiting object. 


10. Click the first frame of the entering object’s motion 
tween. Display the Eases section of the Motion Editor 
and change the Simple (Slow) easing to –100% 
(Figure 13). 


 Changing the easing value adjusts the rate of change 
between tweened frames. Negative easing values cause 
the motion tween to begin slowly and accelerate at the 
end of the tween. A positive value causes the tween to 
begin rapidly and decelerate at the end. The animation 
still takes the same amount of time, regardless of the 
easing value. 


 
Figure 10 Two image symbols in two layers 


 


 
Figure 11 Setting the image Alpha settings 


 


 
Figure 12 Inserting the flip transition in the mid-
point of the Timeline 


 
Figure 13 Eases section of the Motion Editor  
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11. Select Control > Test Movie to test the movie. 


12. Select File > Close to close the preview window. 


 


Motion presets 
You can also add motion presets to your tweened symbol. Motion presets are preconfigured motion tweens you can 
apply to an object on the Stage. You simply select the symbol and click the Apply button in the Motion Presets 
panel. 


To add a motion preset to your symbol: 


1. Open an existing Flash document or create and save a 
new Flash document. 


2. Create a shape and convert to symbol. 


3. Display the Motion Presets panel by selecting Window 
> Motion Presets. 


 You can preview the Motion Presets by clicking on a 
preset from the list of Default Presets (Figure 15) 


4. To apply a motion preset to the symbol on the stage, 
click the Apply button. 


5. Click the Motion Editor tab to find the properties for the 
preset you have just applied. Make any changes you like 
in the Motion Editor. 


6. After making changes to any motion settings in the 
Motion Editor, save your customized motion preset by 
clicking the Save Selection As Preset icon in the lower 
left corner of the Motion Presets panel (Figure 16). 


7. Type a name for your custom preset and click OK. 


 You will now see your motion preset under the Custom 
Presets folder of the Motion Presets panel. You can 
apply your custom motion presets to other tweens in this 
file or new files. Using presets can save significant 
production time during design and development of your 
projects, especially if you use similar kinds of tweens 
often. 


8. Save the movie. 


9. Select Control > Test Movie to test the movie. 


10. Select File > Close to close the preview window. 


 


 
Figure 15 Motion Presets panel 


 


 
Figure 16 Save Selection As Preset icon  
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How to create visual effects 
With Adobe Flash CS4 Professional filters (graphics effects), you can add interesting visual effects to text, buttons, 
and movie clips. You can change text, shapes, and symbols in many ways by adding filters. This guide illustrates 
how to apply specific effects to shapes, how to edit effects, and how to remove effects. You can apply any number 
of effects by using this technique. 


To create a visual effect: 


1. Open an existing Flash document or create and save a 
new Flash document. 


2. From the Tools panel, select the Rectangle tool 
(Figure 1). 


3. For the Rectangle tool, specify rounded corners by 
clicking the Round Rectangle modifier in the Property 
inspector and entering a corner radius value, such as 25 
(Figure 2). 


 A value of zero (0) creates square corners. 


4. To create a rectangle shape, drag the Rectangle tool on 
the Stage. 


 For the Rectangle tool, Shift-drag to constrain the shape 
to squares. (Similarly, you can draw perfect circles by 
Shift-dragging the Oval tool.) 


5. You will need to convert the shape to a symbol. Select 
the rectangle or several elements on the Stage. Do one of 
the following: 


• Select Modify > Convert To Symbol. 


• Drag the selection to the Library panel. 


• Right-click (Windows) or Control-click (Mac OS) 
and select Convert To Symbol from the context 
menu. 


  


 


 
Figure 1 Shape tool options 


 


 
Figure 2 Adjust rectangle options 


Round 
Rectangle 
modifier 
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6. In the Convert To Symbol dialog box, type the name of 
the symbol and select the Movie Clip type (Figure 3). 


 Note: Symbol types include Movie Clip, Button and 
Graphic, and provide different filter options.  


• Use graphic symbols for static images and to create 
reusable pieces of animation that are tied to the 
main Timeline. 


• Use button symbols to create interactive buttons 
that respond to mouse clicks, rollovers, or other 
actions. 


• Use movie clip symbols to create reusable pieces of 
animation. 


7. Click OK. 


 Flash adds the symbol to the library and switches to 
symbol-editing mode. In symbol-editing mode, the name 
of the symbol appears above the upper left corner of the 
Stage, and a cross hair indicates the symbol’s 
registration point. 


8. Select the rectangle object to apply a filter. 


9. In the Filters section of the Property inspector, click the 
Add Filter (+) button, and select a filter, such as the 
Bevel filter (Figure 4).  


 The filter is applied to the object (Figure 5). 


10. Experiment with the filter settings (Figure 6) until you 
get a look you like (Figure 7). 


 


 
Figure 3 Convert To Symbol dialog box 
 


 
Figure 4 Add Filter menu in the Property 
inspector 
 


 
Figure 5 Bevel filter applied to rectangle 
 


 
Figure 6 Bevel filter settings 
 


 
Figure 7 Modified Bevel filter applied to 
rectangle 







Adobe Flash CS4 Activity 6.1 guide 


© 2008 Adobe Systems Incorporated How to create visual effects 3 


Removing and disabling visual effects 
You can remove or disable an effect after you have applied it. 


To remove or disable an effect: 


1. Select the object from which you want to remove a 
filter. 


2. Click the delete icon at the bottom of the Filters section 
of the Property inspector (Figure 8). 


 The effect is removed. 


 You can also enable or disable a filter applied to an 
object by clicking the Enable or Disable Filter icon. 


 
 


Figure 8 Disable/enable or delete a filter 


 


Delete 
 


Enable or  
Disable Filter 
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How to use filmmaking techniques 
Web designers have an entire history of filmmaking techniques to draw from and inspire them when creating 
websites and digital movies. With Adobe Flash CS4, you can simulate traditional film techniques. As you design 
Flash movies, think of creative ways to incorporate these effects and look for opportunities to create new effects that 
may in turn inspire traditional filmmaking. 


You can create the following popular filmmaking techniques with Flash: 


• Pan, tilt, and zoom effects: Moving the camera horizontally across a scene is known as a pan. Moving the 
camera up or down across a scene is known as a tilt. Moving the camera away from or toward a subject in a 
scene is known as a zoom. 


• Camera angles: Using the rule of thirds and adjusting the viewing angle can help emphasize a certain aspect of 
your subject. 


• Cross fades: One image appears to fade in while another fades out, a transitional effect for moving from one 
image to another. 


• Bounce effect: A moving object rebounds before stopping. This technique grabs attention and can focus viewers 
on an area of the screen. This effect is sometimes combined with a sudden sound effect, such as a “boing” or 
tire screech. 


Create a pan, tilt, or zoom effect by using classic tweens 
To set a scene in a movie, the camera moves over a large scene and then zooms in to a specific point. A pan (or tilt) 
followed by a zoom is a good technique to introduce a digital narrative. Zooming in focuses the viewer’s attention 
on a particular part of the image. 


To create a pan and zoom effect: 


1. Open an existing Flash document or create and save a 
new Flash document. 


2. To import an image directly into the current Flash 
document, select File > Import > Import To Stage. 


3. If your image is not already a symbol, convert it to a 
movie clip symbol (Figure 1). Place the symbol on the 
right side of the workspace, covering the Stage. 


 Be sure the Stage is smaller than the image. 


4. In the Timeline, select the keyframe where you want the 
pan to end and select Insert > Timeline > Keyframe 
(Figure 2). 


5. Select the ending keyframe. Drag the instance of the 
movie symbol to the opposite side of the workspace. 


 
Figure 1 Image converted to symbol 


 


 


 
Figure 2 Insert a keyframe 
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6. Click in the Outline column to the right of the name for 
the layer that contains the movie symbol (Figure 3). 


 Note: You can more easily see the border of an image if 
you set the layer holding the image to outline mode 
(especially if the image contains a lot of grays that can 
fade into the area outside the Stage). Be sure the image 
does not slide off the Stage during a pan. 


7. Select the starting frame and select Insert > 
Classic Tween. 


 This classic tween moves the movie symbol horizontally 
across the Stage (a pan). The second keyframe that ends  
the classic tween will also serve as the starting point for 
the next tween. 


8. Add a third keyframe further along in the time line to 
serve as the ending point of the second classic tween (a 
zoom) (Figure 4). 


9. Select the third keyframe and select Modify > 
Transform > Scale to display the Transform panel. 


 Transformation handles appear on the image (Figure 5). 


10. Shift-drag one of the corner transformation handles to 
resize the image approximately three times its original 
size. 


 The image expands. 


11. Select the second keyframe and select Insert > Classic 
Tween creating a classic tween between the second and 
third keyframes. 


12. In the Property inspector, increase the easing to a value 
between 60 and 100 for the classic tween (Figure 6). 


 The zoom will start quickly and slow down as it arrives 
at the resting point. 


13. In the Timeline panel, click the New Layer button. 


14. Rename the new layer actions (Figure 7). 


15. Select the last frame of the actions layer and insert a new 
keyframe. 


 


 
 


Figure 3 Image outlined 
 


 
Figure 4 Keyframe for zoom 
 


 
 


Figure 5 Outline image with transformation 
handles 
 


 
Figure 6 Property inspector 
 


 
 


Figure 6 New Layer button in the Timeline 


 


Transformation handle 


Outline column 


New Layer 
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16. Select Window > Actions to display the Actions panel. 


 The Actions panel opens (Figure 7). 


 Note: If the Actions toolbox is hidden, click the triangle 
or drag the vertical bar to open. If you don’t see the 
parameters area in the Actions panel, click the Script 
Assist button. 


17. You need to place a stop command at the end of the 
timeline to end the movie clip. In the Actions toolbox on 
the left side of the panel, choose flash.display > 
MovieClip > Methods.  


18. Double-click or drag the stop item to the script window 


 The code for the stop method appears in the script 
window. 


 Note: You can also locate the stop and other methods by 
using the Index located at the bottom of the Actions 
toolbox 


19. In the Script pane, select the stop method. Then click in 
the Object text box in the parameters area of the Actions 
panel. 


 The Insert Target Path button is now active. 


20. Click the Insert Target Path button. 


 The Insert Target Path dialog box appears (Figure 8). 


21. Select the Relative option and select the movie clip you 
want to play when viewers click the button. If you want 
the movie in the main timeline to play, select root to set 
the target path to this


21. Click OK to close the Insert Target Path dialog box. 


. 


 The Script pane shows the correct code for stopping the 
movie (Figure 9). 


22. Close the Actions panel. 


21. To test how the SWF file works before you publish your 
SWF file, use Test Movie (Control > Test Movie) and 
Test Scene (Control > Test Scene).  


22. Select File > Close to close the preview window. 


 


 


 
 


Figure 7 Stop method in the Actions panel 


 


 
Figure 8 Insert Target Path dialog box 


 


 
Figure 9 Stop method in the Script pane 
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Insert Target Path button Script Assist button 


Show / hide 
actions 







Activity 6.1 guide Adobe Flash CS4  


4 How to use filmmaking techniques © 2008 Adobe Systems Incorporated 


Adding frame labels 
You may want to add frame labels to the keyframes. Frame labels help you and other designers remember what is 
happening in a particular frame. 


To add a frame label: 


1. Add a new layer called labels as the top layer of the 
Timeline. Insert > Timeline > Blank Keyframe in this 
layer to correspond with each of the motion keyframes 
that drive the animation. A blank keyframe acts as a 
placeholder for symbols you plan to add later or intend 
to leave the empty. 


2. Select a blank keyframe in the labels layer. Then in the 
Property inspector, type the label name in the Name text 
box (Figure 10). 


 The label appears along the Timeline in the frames after 
the blank keyframe (Figure 11). 


3. Turn off outlining, save the file, and select Control > 
Test Movie. 


 
Figure 10 Frame Name text box in Property 
inspector 


 


 
Figure 11 Frame labels in Timeline 


Further ideas 
• For a documentary: Slow the process down to reflect the pace of the narrative. For example, a slow pan and 


zoom go well with a documentary style narrative. 


• For humor or action: Make the zoom-in portion of the pan quick and somewhat unsteady, as if you are looking 
for the subject of the scene. You might zoom in and out several times during a pan to show you are looking for 
something. 


• For drama: Pan or tilt the scene without a zoom. This method presents a sweeping landscape, such as a 
mountain range leading to the ocean. Because it takes in the majority of the landscape, the effect adds depth and 
seriousness to the tone of the narrative. 
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Camera angles 
When you have several images on the screen in a digital narrative, you can use some tricks for emphasis. Use the 
rule of thirds and adjust the viewing angle to emphasize a certain aspect of the subject. 


• The rule of thirds states that if you divide the screen into a 3-by-3 grid, the intersections of the lines are areas 
where the eye will focus. Line up the items of focus at these intersections on the screen. 


• You can add importance to a subject by presenting the subject as seen from below. Likewise, you can diminish 
the importance of a subject as seen from above. 


Even though the girl isn’t in the center of Figure 12, she 
catches your eye because she is near the intersection of the 
rule-of-thirds lines. 


Looking up at the man having a moment in Figure 13 makes 
him look powerful. Angling the camera down on him would 
make him look smaller and less powerful. 


 
Figure 12 Rule of thirds 


 
Figure 13 Camera angle 
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Create cross fades by using classic tweens 
A transitional effect for moving from one image to another is to fade one image out as you fade the other in. 


To create a cross fade: 


1. Open an existing Flash document or create and save a 
new Flash document. 


2. Import two images into the current Flash document, 
select File > Import > Import To Stage. 


3. Convert the two images to be cross-faded into symbols, 
and place them on separate layers. 


4. Insert keyframes in both layers at the same point in the 
Timeline to mark the beginning of the fade-out of the 
first image and the fade-in of the second image. 


5. Decide how long you want the transition to last. Insert 
keyframes in both layers at the same point in the 
Timeline to mark the end of the fade-out of the first 
image and the fade-in of the second image. 


6. Select the first keyframe for the image that will fade out, 
select the image, and use the Property inspector to set its 
alpha level to 100% (Figure 14). 


 Note: If your images are in the same position on the 
Stage, you need to hide the top layer before you can 
select the symbol in the bottom layer. Selecting your 
images is easier if they are offset on the Stage. 


7. Select the first keyframe for each image and insert a 
classic tween. 


8. Select the first keyframe for the image that will fade in 
and set its alpha level to 0%. 


9. Select the last frame for the image that will fade in and 
set its alpha level to 100%. 


10. Select the last frame for the image that will fade out and 
set its alpha level to 0%. 


11. Add Frame labels to the first keyframes of each classic 
tween (Figure 15). 


 The labels appear on the Timeline (Figure 16). 


 Note: You can make the fade-out start after the fade-in 
or vice versa. You can also extend the fade-out to end in 
the same frame as the end of the fade-in. 


 If the images zoom in or out before the fade-out, you 
probably want to continue the zooming process during 
the fade. 


12. Save the movie. 


13. Select Control > Test Movie to test the movie. 


14. Select File > Close to close the preview window. 


 
Figure 14 Applying an Alpha level in the Color 
Effect Style menu 


 


 
Figure 15 Frame label text box 


 


 
Figure 16 Frame labels in Property inspector 
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Create a bounce effect by using classic tweens 
Some animated text and images that move onto the Stage will seem more lifelike if you add a little bounce to them 
when they reach their stopping point. This is an old animation technique acknowledging that any moving object 
carries momentum and thus rebounds a bit before it comes to a stop. This technique also grabs attention and can 
focus viewers on an area of the screen. 


To create a bounce effect: 


1. Open an existing Flash document or create and save a 
new Flash document. 


2. Begin by adding a symbol to the Stage. By default the 
symbol is placed in the first keyframe of the timeline. 


3. Select a second frame along the timeline. 


4. Select Insert > Timeline > Keyframe. 


5. Make sure the new frame is still selected and move the 
symbol to a new position on the Stage. 


6. Click on the tween span on the Timeline and select 
Insert > Classic Tween.  


 The classic tween appears as light blue with an arrow  


7. Label the starting keyframe for the classic tween move 
right or move left (Figure 17) and label the second 
keyframe bounce. 


8. Insert a keyframe 3–5 frames after the end of the classic 
tween. Label this frame back. 


9. Insert another keyframe 8–10 frames after the end of the 
original classic tween. This will be the final resting point 
of the image. Label this frame end. 


 Note: If you want the final bounce back into place to 
take longer (more frames) so the object appears to slow 
down, insert the keyframe in this step farther down the 
Timeline. 


10. Select the keyframe labeled Back. 


11. In this keyframe, select the symbol instance on the Stage 
and use the arrow keys to move the instance 5–10 key 
presses back in the direction it came from. 


12. Create classic tweens between all the keyframes by 
clicking on each tween span and selecting Insert > 
Classic tween. 


13. Add an actions layer to the top of the Timeline. 


 


 
Figure 17 Frame label 


 


 
Figure 18 Actions panel 


 


 
Figure 19 Final timeline 
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14.  On this layer, insert a keyframe after the last frame and 
add a stop action. In the Actions toolbox on the left side 
of the panel, choose flash.display > MovieClip > 
Methods  


15. Double-click or drag the stop item to the script window 


 The code for the stop method appears in the script 
window. 


16. In the Script pane, select the stop method. Then click in 
the Object text box in the parameters area of the Actions 
panel. 


 The Insert Target Path button is now active. 


17. Click the Insert Target Path button. 


 The Insert Target Path dialog box appears.  


18. Select the Relative option and select the movie clip you 
want to play when viewers click the button. If you want 
the movie in the main timeline to play, select root to set 
the target path to this. 


19. Click OK to close the Insert Target Path dialog box. 


 The Script pane shows the correct code for stopping the 
movie (Figure 18). 


 The Timeline should appear as it does in Figure 19. 


20. Close the Actions panel. 


21. To test how the SWF file works before you publish your 
SWF file, use Test Movie (Control > Test Movie) and 
Test Scene (Control > Test Scene).  


22 Select File > Close to close the preview window. 


 
Figure 18 Actions panel 


 


 
Figure 19 Final timeline 


 







Adobe Flash CS4 Activity 5.3 guide 


© 2008 Adobe Systems Incorporated How to produce Flash video for use on the web 1 


How to produce Flash video for use on the web 
Adobe Flash CS4 provides a number of options for importing and publishing video with a Flash movie. 


You can import the following video formats: 


• Video for Adobe Flash (.flv, .f4v) 


• 3GPP/3GPP2 for mobile devices (.3gp, .3gpp) 


You can import the following video formats if you have QuickTime 7 or later installed (Windows and Mac OS): 


• Audio Video Interleaved (.avi) 


• Digital Video (.dv) 


• Motion Picture Experts Group (.mp4, .m4v, .avc) 


• QuickTime Movie (.mov, .qt) 


You can import the following file formats if you have DirectX 9 or later installed (Windows only): 


• Audio Video Interleaved (.avi) 


• Motion Picture Experts Group (.mpg or .mpeg) 


• Windows Media File (.wmv, .asf) 


Deploying video 
How you choose to deploy your video determines how you create your video content and how you integrate it with 
Flash. You can incorporate video into Flash in the following ways: 


Progressively download video from a web server: Flash creates a Flash video file that downloads from a regular web 
server and plays within the published SWF file. 


Stream video with Adobe Flash Media Server: This option produces the overall best performance; however, it 
requires either the Flash Media Server or a subscription to a Flash Video Streaming service. See the Adobe website 
for more information: www.adobe.com. 


Embed video in the Flash document: You can embed a small, short-duration video file directly into the Flash 
document and publish it as part of the SWF file. Embedding video content directly into the Flash SWF file 
significantly increases the size of published file and is only suitable for small video files (typically less then 
10 seconds in length). 


To encode your video for Flash: 


1. Open an existing Flash document or create and save a 
new Flash document. 


 Note: You must save the Flash document before you 
begin the video import process. 


2. Select a keyframe on the layer in which you want to 
import the video. 


 This is where the video player will be located after the 
video import is complete. 


 



http://www.adobe.com/�
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3. Click File > Import > Import Video. 


 The import Video dialog box appears (Figure 1). 


4. Click the Launch Adobe Media Encoder button. 


 The Adobe Media Encoder appears (Figure 2). 


5. In the Media Encoder, click the Add button and browse 
to the location for the video file you want to encode. 


6. Choose an appropriate Format, Preset (Figure 3), and 
Output File location in the Media Encoder. 


7. Click the Start Queue button to begin encoding. 


 When the encoding process is complete, close the Adobe 
Media Encoder.  


 


 
Figure 1 Import Video dialog box  


 


 
Figure 2 Adobe Media Encoder 


 


 
Figure 3 Preset options for encoding video 
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To use progressive download: 


1. Click File > Import > Import Video. 


 The import Video dialog box appears (Figure 4). 


 2. Click the browse button to find the location for the 
newly encoded video file you want to import. 


 You can use a video file located either on your computer 
or on the Internet. 


3. Select Load External Video With Playback Component. 


 This option progressively loads your external video file 
into your Flash document. 


4. Click Next (Windows) or Continue (Mac OS). 


 The Skinning page of the Import Video wizard appears 
(Figure 5). 


 The video’s skin determines the location and appearance 
of the video controls. Visitors see this skin when Flash 
plays the video. 


5. Select a skin from the Skin pop-up menu. 


6. Select a skin color from the color picker. 


7. Click Next (Windows) or Continue (Mac OS). 


 The Finish Video Import page of the Import Video 
wizard appears. This page confirms the location of the 
Flash video file. 


8. Click Finish. 


 The FLVPlayback object appears on the Stage 
(Figure 6). 


9. Select Control > Test Movie to see it play. 


 The video plays in the Flash Player window. You can 
use the controls to stop, pause, fast forward, rewind, and 
change the volume of the video. 


10. Select File > Close to close the preview window. 


11. Open the folder in which you saved the Flash document. 


 This folder now contains two new files: an FLV file and 
a SWF for the video’s skin. (The skin will be called 
something like MojaveOverAll.swf.) When you publish 
your Flash document, you need to copy both of these 
files to the same location as the Flash document. 


 
Figure 4 Import Video wizard, Select Video page 


 


 
Figure 5 Import Video wizard, Skinning page 


 


 
Figure 6 FLVPlayback object on Stage 
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Embedding video within SWF files 


When you select the embedded video option, Flash converts video to Timeline frames. When the SWF file is 
published, the video is fully contained in that file. Unlike progressive download, embedded video requires no 
external file and so is easier to deploy. However, because embedded video often has problems with audio 
synchronization after 120 frames, Adobe recommends embedded video in only three cases: 


• When you want visitors who have Flash 5 to be able to view your video 


• When you must have one single file that encapsulates the video and the Flash content 


• When your video clip is less than 5 seconds long 


These situations are not common. In all other situations, embedded video is not recommended. 






















































