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Adobe Web Communication using Dreamweaver CS4 
EXAM AND OBJECTIVES 


After taking the exam, your score is electronically reported.  Please allow 2-4 weeks from the date you pass the exam to 
receive your ACA Welcome Kit. 


Exam Topics 
 The following lists the topic areas covered in the exam:  


• Setting Project Requirements 
• Planning Site Design and Page Layout 
• Understanding the Adobe Dreamweaver CS4 Interface 
• Adding Content by Using Dreamweaver CS4 
• Organizing Content by Using Dreamweaver CS4 
• Evaluating and Maintaining a Site by Using Dreamweaver CS4 


Number of Questions, Time and Passing Score  
• Ranges from 35-40 questions 


• Allow for up to 60 minutes to test 


 
Exam Objectives 
Domain 1.0 Setting Project Requirements 


1.1 Identify the purpose, audience, and audience needs for a website. 


1.2 Identify web page content that is relevant to the website purpose and appropriate for the target audience. 


1.3 Demonstrate knowledge of standard copyright rules (related terms, obtaining permission, and citing copyrighted 
material).  


1.4 Demonstrate knowledge of website accessibility standards that address the needs of people with visual and motor 
impairments. 


1.5 Make website development decisions based on your analysis and interpretation of design specifications. 


1.6 Understand project management tasks and responsibilities. 


 


Domain 2.0 Planning Site Design and Page Layout 


2.1 Demonstrate general and Dreamweaver-specific knowledge of best practices for designing a website, such as 
maintaining consistency, separating content from design, using standard fonts, web-safe colors, and utilizing visual 
hierarchy. 


2.2 Produce website designs that work equally well on various operating systems and browser versions/configurations.  


2.3 Demonstrate knowledge of page layout design concepts and principles. 


2.4 Identify basic principles of website usability, readability, and accessibility. 
2.5 Demonstrate knowledge of flowcharts, storyboards, and wireframes to create web pages and a site map (site 


index) that maintain the planned website hierarchy. 


2.6 Communicate with others (such as peers and clients) about design and content plans. 


 


Domain 3.0 Understanding Adobe Dreamweaver CS4 Interface 


3.1 Identify elements of the Dreamweaver interface. 


3.2 Use the Insert bar. 


3.3 Use the Property inspector. 


3.4 Use the Assets panel. 


3.5 Use the Files panel. 
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Domain 4.0 Adding Content by Using Dreamweaver CS4 


4.1 Define a Dreamweaver site. 


4.2 Create, title, name, and save a web page. 


4.3 Add text to a web page. 


4.4 Insert images and apply alternative text on a web page. 


4.5 Link web content, using hyperlinks, e-mail links, and named anchors. 


4.6 Insert rich media, such as video, sound, and animation in Flash format. 


4.7 Insert navigation bars, rollover images, and buttons created in Fireworks on a web page. 


4.8 Build image maps. 


4.9 Import tabular data to a web page. 


4.10 Import and display a Microsoft Word or Microsoft Excel document to a web page. 


4.11 Create forms. 


 


Domain 5.0 Organizing Content by Using Dreamweaver CS4 


5.1 Set and modify document properties. 


5.2 Organize web page layout with absolutely-positioned div tags and CSS styles. 


5.3 Modify text and text properties. 


5.4 Modify images and image properties. 


5.5 Create web page templates. 


5.6 Use basic HTML tags to set up an HTML document, format text, add links, create tables, and build ordered and 
unordered lists. 


5.7 Add head content to make a web page visible to search engines.  


5.8 Use CSS to implement a reusable design. 


 


Domain 6.0 Evaluating and Maintaining a Site by Using Dreamweaver CS4 


6.1 Conduct basic technical tests. 


6.2 Identify techniques for basic usability tests. 


6.3 Identify methods for collecting site feedback. 


6.4 Present web pages to others (such as team members and clients) for feedback and evaluation. 


6.5 Manage assets, links, and files for a site. 


6.6 Publish and update site files to a remote server. 
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Dear Candidate, 


In preparation for the Web Communication certification exam, we’ve put together a set of practice 


materials and example exam items for you to review.  What you’ll find in this packet are: 


 Topic areas and objectives for the exam.  


 Practice materials with image assets. 


 Practice exam items. 


We’ve assembled excerpted material from the Digital Design Curriculum guide to highlight a few of the 
more challenging techniques covered on the exam.  You can work through these technical guides with 
the provided image and video files (provided separately). Additionally, we’ve included the certification 
objectives so that you are aware of the elements that are covered on the exam. Finally, we’ve included 
practice exam items to give you a feel for some of the items.  


These materials are meant to help you familiarize yourself with the areas of the exam so are not 
comprehensive across all the objectives. 


Thank you, 


Adobe Education 












Practice Exam  
Try out these practice questions to get a feel for the types of questions on the ACA exam. Please note that 
your performance here does not indicate how you will do on the actual exam. The actual exam is 
approximately one-half multiple-choice questions similar to the questions in this document, and 
approximately one-half simulation questions where you will be asked to perform a task in the 
Dreamweaver CS4 application. To fully prepare for the exam, closely review the topic areas and 
objectives.  
 
1. Which term describes a Dreamweaver site that has not been published to a remote server? 


A.  Local site 
B.  Root folder 
C.  Local folder 
D.  Remote Site 


 
Correct answer:  B 
 
2. Choose the two best options to add an email link to a Web site. 


A.  Add an HREF<mailto> tag 
B.  Insert an HREF<hyperlink> tag 
C.  Use the Link Target command 
D.  Insert a named anchor in the page 
E.  Use the Insert Email Link command 


 
Correct answer:  A and E 
 
3. Choose the tab you would use to insert a navigation bar. 


A.  Data 
B.  Spry 
C.  Layout 
D.  Common 


 
Correct answer:  D 
 
4. Which two elements constitute a rollover image? 


A.  Original image 
B.  Shading image 
C.  Element image 
D.  Rollover image 
E.  Secondary image 


 
Correct answer:  A and D 
 
5. Which two file types can be imported using the File > Import command? 


A.  MS Excel files (.XLS) 
B.  MS Visio files (.VSD) 
C.  MS Word file (.DOC) 
D.  MS PowerPoint files (.PPT) 
E.  Adobe Photoshop files (.PSD) 


 
Correct answer:  A and C 
 







6. Which two view types are available in the Files panel? 
A.  Map view 
B.  Code view 
C.  Server view 
D.  Remote view 
E.  Browser Preview 


 
Correct answer:  A and D 
 
7. Choose the right command that will download files from a remote site to the local machine. 


A.  The Upload Files command 
B.  The Preview Site command 
C.  The Synchronize Sitewide command 
D.  The Check Links Sitewide command 


 
Correct answer:  A 
 
8. Why does a Web designer perform a client survey  during the planning phases of a Web site? 
 A.  Because the survey responses help the Web designer understand client needs 


B.  Because the survey responses help the Web designer build the client’s Web site structure 
C.  Because the survey responses give the Web designer an understanding of the target audience needs 
D.  Because the survey responses determine the Web designer’s billing costs for developing the client’s 
Web site 


 
Correct answer:  A 
 
9. Choose three ways to make a website more credible. 


A.  Make the website small 
B.  Have short web addresses 
C.  Have the site updated often 
D.  Make it easy to be contacted 
E.  Make it easy to verify information 
F   Have large graphics on the web pages 
 


Correct answer: C, D, and E 
 
10. Select contents protected by copyright laws. 


A.  Copyright laws protect works worldwide 
B.  Copyright laws protect only published works 
C.  Copyright laws protect only registered works 
D.  Copyright laws protect both published and unpublished works 


 
Correct answer:  D 
 
11. What kind of written material can be used without first obtaining copyright permission? 
 A.  Original material 


B.  Copyrighted material 
C.  Unpublished material 
D.  Public domain material 


 
Correct answer:  D 
 







12. When describing websites, what is meant by the term "accessible"? 
A.  Web site usability for all, including those with disabilities 
B.  Organization of Web site for optimal bandwidth considerations 
C.  Efficiency of navigation for users to move through a Web site transaction 
D.  The configuration of computers and software needed for optimal performance 


 
Correct answer:  A 
  
13. Select the three Web page content types that are interpreted by screen readers. 
 A. Videos 


B. Images 
C. Page Titles 
D. Page body text 
E. Column headers 
F. Graphic headers 


 
Correct answer:  B, E, and F 
 
14. Choose two questions that contain the most common concerns when adding images to a Web site. 
 A.  What is the file size of the image? 
 B.  What is the file name of the image? 


C.  Is this the correct type of image file? 
D.  Is the image relevant to the Web site? 
E.  Is a pixel border required around the image? 


 
Correct answer:  A and D 
 
15. How many colors do all browsers recognize? 


A.  15 
B.  16 
C.  24 
D.  32 


 
Correct answer:  B 
 
16. Choose the two ways to improve end-user download speed. 


A.  Use cascading style sheets for page layout 
B.  Use the alt tag for large images 
C.  Use thumbnails for large images 
D.  Use tables for presentation and format 


 
Correct answer:  A and C 
 
17. What is the advantage of optimizing images before adding them to a Web page? 


A.  Sharpened images 
B.  Improved formatting 
C.  Reduced download time 
D.  Reduced development time 


 
Correct answer:  C 
 







18. Which three site items should remain consistent throughout a Web site? 
A.  Page layout 
B.  Content type 
C.  Font formatting 
D.  Quantity of text 
E.  Image placement 
F.  Navigation buttons 


 
Correct answer:  A and C 
 
19. How many colors does  the web-safe color palette contain? 
 A.  144 


B.  216 
C.  256 
D.  360 


 
Correct answer:  B 
 
20. Choose an attribute that maintains consistency throughout a Web site. 
 A.  File size 


B.  File type 
C.  Page layout 
D.  Protocol layout 


 
Correct answer:  C 
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How to lay out a web page with CSS 
You can use table design features in Adobe Dreamweaver CS4 to create a simple page layout. However, a more 
powerful technique is to use Cascading Style Sheets (CSS). The basic building block of CSS layout is the div tag—
an HTML tag that in most cases acts as a rectangular container for text, images, and other page elements. When you 
create a CSS layout, you place div tags (or divs) on the page, add content to them, and position them in various 
places. Unlike table cells, which are restricted to existing somewhere within the rows and columns of a table, divs 
can appear anywhere on a web page. You can position divs absolutely (by specifying x- and y-coordinates), or 
relatively (by specifying their distance from other page elements). 


In Dreamweaver, you can quickly and easily place an AP div (short for absolutely positioned div tags). These 
elements provide great control over the page layout, reduce the amount of code you need, and enable you to format 
layout blocks with margins, borders, and colors. In addition, people using screen readers to view web pages have a 
much easier time browsing pages built with CSS because the code is simpler and shorter. The limitation of an AP 
div, however, is that since it is absolutely positioned, its position never adjusts on the page to accommodate to the 
size of the browser window. 


You will learn more about CSS in later units. 
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Creating a new page 


1. Start Dreamweaver. 


2. Make sure the Files panel is visible (Figure 1).  


 In Windows, it is docked at the right side of the screen. 
If the Files panel is not open, select Window > Files. 


3. Make sure your portfolio site is selected. If it is not, 
click the Site pop-up menu and select your portfolio site. 


4. Select File > New. 


 The New Document dialog box opens (Figure 2). 


5. With the Blank Page category selected under Page Type, 
click HTML. 


6. Click Create. 


 A new untitled HTML document opens. 


7. To save the untitled document as your home page, select 
File > Save As. 


 The Save As dialog box opens to the root folder of your 
portfolio site automatically. 


8. Name the new page index.html and click Save. 


 The new file, index.html, is added to the root folder in 
the Files panel (Figure 3). 


 


 


 
Figure 1 Files panel 
 


 
Figure 2 The New Document dialog box 
 


 
Figure 3 Files panel showing index.html 


Site menu 
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Inserting a div tag 


1. Select the Layout category in the Insert bar. 


 Make sure the Standard mode button is selected 
(Figure 4). 


2. Click the Draw AP Div button (Figure 4). 


 The mouse pointer changes to a cross when you move it 
over the page. 


3. Select one of the page areas on your storyboard. To 
create the div that will define this area on your page, 
drag a rectangle in the Dreamweaver document. When 
the rectangle matches the page area’s size on your 
storyboard, release the mouse button.  


4. Click the border of the div to select it. 


 Handles appear along the border (Figure 5) and the div 
properties appear in the Property inspector.  


4. Make sure the Property inspector is open (Figure 6).  


 In Windows, it is docked at the bottom of the screen. If 
the Property inspector is not open, select 
Window > Properties. 


5. Click in the CCS-P Element ID box (Figure 6) and enter 
a name for the div.  


 Choose a unique name that will help you remember the 
div’s contents, such as header or navigation. 


 Note: “CSS-P” is a commonly accepted abbreviation for 
“CSS Positioning”. 


6. Click the Bg color box and select a color in the color 
picker.  


 The div changes to the selected color. 


7. Open the AP Elements panel (Window > AP Elements).  


 You’ll see that Dreamweaver has added the new div to 
the list of AP Elements.  


8. Click once outside the new div to deselect it.  


 A thin black line appears around the div. This line does 
not appear in a browser. If you do not see the line, select 
View > Visual Aids > CSS Layout Outlines. 


9. Continue adding divs for all the sections on your 
storyboard. You can place divs directly alongside one 
another (Figure 7). 


10. Save your page. 


 


 
Figure 4 Insert bar, Layout category 


 


 
Figure 5 Div inserted and selected 


 


 


 
Figure 6 CSS-P Element ID Property inspector 


 


 
 


Figure 7 Multiple divs on page 
 


AP Elements panel 


Draw AP Div button 


CSS-P Element ID box 
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Resizing divs 
You can resize an individual div or simultaneously resize multiple divs to make them the same width and height. 


Note: If the Prevent Overlaps option is selected in the AP Elements panel, you will not be able to resize a div so it 
overlaps with another div. 


1. Select a div by clicking its border or by clicking the 
div’s name in the AP Elements panel. 


2. Do one of the following to resize the div: 


• To resize by dragging, drag any of the div’s resize 
handles (Figure 8). 


• To resize one pixel at a time, hold down Control 
(Windows) or Option (Mac OS) while pressing an 
arrow key. 


 Note: The arrow keys move the right and bottom 
borders of the div; you can’t resize the top and left 
borders with this technique. 


• In the Property inspector, type values for width (W) 
and height (H). 


 
 


Figure 8 Resize by dragging 


Moving divs 
You can move divs in Design view in much the same way you move objects in most basic graphics applications. 


To move one or more selected divs: 


1. Select one or more divs. 


2. Do one of the following: 


• To move by dragging, drag the div’s selection 
handle (Figure 9). 


• To move one pixel at a time, use the arrow keys. 


 Note: If the Prevent Overlaps option is selected in the 
AP Elements panel, you will not be able to move a div 
so that it overlaps another div. 


 
Figure 9 Moving a div 


 


Div resize handle 


Selection 
handle 
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Adding content to divs 
You can add images, text, and other content (such as Flash movies) to your divs just as you would elsewhere in a 
web page. 


1. To insert an image in a div, click in the div and select 
Insert > Image on the menu bar. 


 Note: Make sure the div is sized large enough to hold 
the image or other content. If the div is sized smaller 
than the image, the div may not display correctly in all 
browsers. 


2. In the Select Image Source dialog box, locate and select 
an image to insert (such as your page banner). Then 
click OK (Windows) or Choose (Mac OS). 


 The image appears on the div (Figure 10). 


3. To format the image in the div, select the image and 
select formatting elements in the Property inspector. 


4. To add text to a div, click in the div and type text or 
paste text copied from another document. 


 
Figure  10 Div with image added 


Previewing a page 
You can add images, text, and other content (such as Flash movies) to your divs just as you would elsewhere in a 
web page. 


 To preview the page in a browser (Figure 11), select 
File > Preview In Browser and then select a browser 
from the submenu (or press F12). 


 Note: It is important to preview in a browser to make 
sure your design fits in a standard browser window. Try 
resizing the browser window to see the effect on your 
page. 


 


 
Figure 11 Web page in a browser window 


 







Adobe Dreamweaver CS4 Activity 3.6 guide 


© 2008 Adobe Systems Incorporated How to create Cascading Style Sheets 1 


How to create Cascading Style Sheets 
Cascading style sheets (CSS) are collections of formatting rules that control the appearance of content on a web 
page. By using style sheets, you can achieve greater consistency across your website (even if your site consists of 
only one page). CSS styles provide you with a wide range of options for formatting text. This guide shows you how 
to take advantage of Cascading Style Sheets to maintain consistency and to apply characteristics to text. 


If you’ve been using Adobe Dreamweaver CS4, you may have been using CSS without knowing it. Dreamweaver 
formats all text with CSS by default. Every time you change certain text properties in the Property inspector, such as 
text size and text color, Dreamweaver prompts you to define a mew CSS rule or update a style for the text. 
Dreamweaver places these style definitions in the beginning of each web page’s code. A collection of these 
definitions is known as an internal style sheet, because it is contained within an individual web page. 


Internal style sheets (sometimes called embedded style sheets) are great for maintaining consistency within a 
document, but Cascading Style Sheets are especially useful for maintaining consistency across a number of different 
pages. By using an external style sheet—a separate document that holds CSS style information—you can make sure 
that text appearance is consistent across multiple pages. Not only does a consistent appearance look more 
professional, but usability experts say that site visitors find what they’re looking for more easily on sites where text 
appearance and placement is consistent. 


Defining CSS styles 
The most basic way to define CSS styles in Dreamweaver is to apply formatting by using the CSS options in the 
Property inspector. When you do, you are prompted to create a new CSS rule. You need to name the new rule and 
define the type of CSS. 


There are three main types of CSS: 


A Class style is similar to the styles you use in word processing and page layout programs. For example, you may 
want to format all body text in 10-point, Arial, dark green type. You can create a Class style with these attributes 
and then apply this style to all body text in your web site.  


A Tag style applies global formatting to individual HTML tags, as opposed to individual selections. Suppose you 
want to modify the Heading 1 paragraph style to always appear in purple text. Instead of creating a class style and 
applying it to every heading in the document, you can create an HTML Tag style with these attributes and apply it to 
the Heading 1 <h1> tag. In effect, you are redefining the HTML tag. 


An ID style is only used once within a document or page. It is used as a unique identifier (ID) for a style applied to 
elements such as a header, banner, or menu that is only present in one location in the document. 


A Compound style is used to format text in different ways based on how a user interacts with the text. For example 
you can use a compound style to change the look of text when a user rolls over a link.  


Whenever possible, redefine existing tags instead of creating new CSS styles. The existing tags provide a useful 
hierarchy for both you and the users of your site, and they also make it easier for people using screen readers to use 
your site. 


In addition to using the CSS options in the Property inspector, you can define, apply, and modify CSS styles by 
using the CSS panel, which you will do in this guide. 
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To redefine an existing HTML style tag by using a CSS Tag rule: 


1. Start Dreamweaver. 


2. Create a new HTML document. 


3. Save and name the Dreamweaver document. 


4. Type some text in the document. 


5. Select the text. 


6. Using the Property inspector, apply an HTML tag such 
as Heading 1 to the text. 


 The text appears in the default Heading 1 format 
(Figure 1).  


7. Make sure the CSS Styles panel is open and expanded. 


 If it is not open, select Window > CSS Styles.  


8. To create a new style, click the New CSS Rule 
button (+) at the bottom of the CSS panel (Figure 2). 


 The New CSS Rule dialog box opens (Figure 3). 


9. In Selector Type pop-up menu, select Tag.  


 This option lets you add CSS properties to an existing 
HTML tag. 


10. From the Selector Name pop-up menu, select h1 (the tag 
for Heading 1). 


11. In the Rule Definition pop-up menu, select This 
Document Only or New Style Sheet File.  


 The option This Document Only defines the style as part 
of the document’s internal style sheet. The option New 
Style Sheet File defines the style as part of an external 
style sheet. 


12. Click OK. 


 Note: If you choose to create an external style sheet by 
selecting New Style Sheet File, you are prompted to 
select a location for the new style sheet (.css) document.  


 
Figure 1 Text with default Heading 1 tag applied 


 


 
Figure 2 CSS Styles panel 


 


 
Figure 3 New CSS Rule dialog box 


New CSS Rule button 
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 The CSS Rule Definition dialog box opens with the 
Type category selected (Figure 4). The dialog box has 
the options listed below. (For more details, select 
Help > Dreamweaver Help.) 


• Type changes text properties such as font, size, and 
color. 


• Background controls background properties. For 
example, you can use a colored background or an 
image or create a fixed or scrolling background. 


• Block controls spacing and alignment of text and 
lines on the document. 


• Box changes the box that surrounds a block 
element. It affects properties such as height, width, 
padding, and margins. 


• Border changes the border properties around text, 
such as style, width, and color. 


• List controls list properties such as text type and 
bullet appearance. 


• Positioning defines text position on the page. 


• Extensions controls page breaks and the visual 
appearance of the cursor. 


13. Select options for Type, such as the following 
(Figure 5): 


• Select Verdana, Arial, Helvetica, Sans-serif from 
the Font-family pop-up menu. 


• Select 14 from the Font-size pop-up menu, and 
select px (pixels) for the measurement unit (in the 
pop-up menu to the immediate right of the Font-size 
pop-up menu). 


• Type #006600 in the Color box, or select a color in 
the Color picker. 


 Note: All Heading styles are bold by default. If you 
don’t want the text to be boldface, select Normal from 
the Weight pop-up menu. 


14. Click Apply.  


 Observe that the Heading 1 text, or the text you chose, in 
the document has changed. (You may need to move the 
dialog box.) 


15. To change the background, select Background in the 
Category pane on the left. 


 The Background category of the CSS Rule definition 
dialog box opens (Figure 6). 


16. Select a color in the Color picker or type a hexadecimal 
number in the Background color dialog box, such as 
#CCCCCC. (Make sure the background color is lighter 
than the color of the text.) 


 
Figure 4 CSS Rule Definition dialog box  


 


 
Figure 5 CSS Rule Definition dialog box showing 
type options 


 


 
Figure 6 CSS Rule Definition dialog box showing 
background options 
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17. Click Apply to see your changes. 


18. To change the border and its properties, select Border in 
the Category pane. 


 The Border category of the CSS Rule Definition dialog 
box opens (Figure 7). 


19. Under Style, you can make changes such as deselecting 
the option Same For All and selecting the option Solid 
in the Top pop-up menu. 


20. Under Width, you can make changes such as typing 1 in 
the Top pop-up menu, and leaving pixels selected as the 
measurement unit. 


21. Under Color, you can make changes such as entering 
#006600, or whatever color you chose in step 13. 


22.  Click OK.  


 The CSS Rule Definition dialog box closes. 


 Observe that the appearance of the Heading 1 text you 
created has now changed (Figure 8).  


23. Make sure the CSS Styles panel is open. 


 If it is not, select Window > CSS Styles.  


24. Make sure that All is selected in the CSS Styles panel. 


 Observe that the h1 style now appears under <style> in 
the All Rules area, indicating that this tag is part of the 
style sheet. Also observe that properties for this tag 
appear in the Properties area (Figure 9). 


25. To make further changes to the tag style, select it and 
click the Edit Rule button.  


 The CSS Rule Definition dialog box opens. Make any 
changes you wish. When you are finished, click OK. 


 Note: You can also make changes using the Properties 
area of the CSS Styles panel, but it is easier to make 
changes using the CSS Rule Definition dialog box. 


26. To apply the style to new text, select the text and then 
select Heading 1, or the tag you modified, in the Text 
Property inspector. 


 
Figure 7 CSS Rule Definition dialog box showing 
options for formatting borders 


 


 
Figure 8 Text with new style formatting applied 


 


 
Figure 9 Style added to CSS Styles panel 


Edit Rule 
button 


CSS Tag rule 


Properties of 
selected rule 
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To create a new CSS Class rule: 


1. Start Dreamweaver. 


2. Create a new HTML document. 


3. Save and name the Dreamweaver document. 


4. Type some text in the document. Make sure that no 
formatting is applied to the text (Figure 10). 


5. Make sure the CSS Styles panel is open. 


 If it is not, select Window > CSS Styles. 


6. To create a new style, click the New CSS Rule 
button (+) at the bottom of the panel. 


 The New CSS Rule dialog box opens (Figure 11). 


7. In the Selector Type pop-up menu, select Class.  


 This option creates a new Class rule. 


8. In the Selector Name box, type a name for the style such 
as .warning. 


 Note: Class rule names must begin with a period and 
cannot contain spaces or special characters. If you forget 
to type the period, Dreamweaver will add this 
automatically. 


9. In the Rule Definition pop-up menu, select This 
Document Only or New Style Sheet File.  


 This Document Only option defines the style as part of 
the document’s internal style sheet. New Style Sheet File 
option defines the style as part of an external style sheet. 


 Note: If you select to create an external style sheet by 
selecting New Style Sheet File, you are prompted to 
select a location for the new style sheet (.css) document. 


10. Click OK. 


 The CSS Rule Definition dialog box opens (Figure 12). 


11. Select the options for Type, such as the following 
(Figure 12):  


• Select Arial, Helvetica, Sans-serif in the Font-
family pop-up menu 


• Select 12 from the Size-size pop-up menu, and 
select px (pixels) for the measurement unit. 


• Type #CC0033 in the Color box, or click the color 
box and select a color in the Color Picker. 


 
Figure 10 Text with no formatting applied 


 


 
Figure 11 New CSS Rule dialog box 


 


 
Figure 12 CSS Rule Definition dialog box 
showing type options  
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12. To change the formatting of text blocks, select Block in 
the Category pane. 


 The Block category of the CSS Rule Definition dialog 
box opens (Figure 13). 


13. In the Letter-spacing box, you can make changes such as 
typing 3 and selecting pixels for the measurement unit. 


 This setting adds space between each letter.  


14. In the Text-indent box, you can make changes such as 
typing 5 and selecting pixels for the measurement unit. 


 This indents the first line of each paragraph. 


15. Click OK. 


 The CSS Rule Definition dialog box closes. 


16. Select the document text. 


17. Make sure the Property inspector is open and the HTML 
option is selected. 


 In Windows, the Property inspector is docked at the 
bottom of the screen. If the Property inspector is not 
open, select Window > Properties. 


18. Select warning, or the name of your style, from the 
Class pop-up menu (Figure 14). 


19. In the document, deselect the text by positioning the 
mouse pointer next to it and clicking once. 


 Observe that the format of the text has changed 
(Figure 15). 


20. Make sure the CSS Styles panel is open. 


 If it is not, select Window > CSS Styles.  


21. Make sure that All is selected in the CSS Styles panel. 


 Observe that the newly created CSS rule now appears 
under <style> in the All Rules area, indicating the new 
rule is part of a CSS style sheet. Also observe that 
properties for the style appear in the Properties area. 


22. To make further changes to the style, select it and click 
the Edit Rule button.  


 The CSS Rule Definition dialog box opens. 


 Note: You can also make changes using the Properties 
area of the CSS Styles panel. 


 
Figure 13 CSS Rule Definition dialog box 
showing options for formatting text blocks 


 


 
Figure 14 Text Property inspector 


 


 
Figure 15 Formatting applied to text 
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Exporting CSS rules to an external style sheet 
You can convert an internal CSS style sheet to an external one by exporting it, removing the internal CSS style 
sheet, and attaching the exported CSS style sheet to one or more web pages.  


To export a style sheet: 


1. Make sure the CSS Styles panel is open (Figure 16). 


 If it is not, select Window > CSS Styles.  


2. Make sure that All is selected in the CSS Styles panel. 


3. Select the CSS rule you want to move to an external 
style sheet. 


 Note: To move more than one rule at a time, you can 
Shift-click to select multiple rules that are next to each 
other. To select multiple rules that aren’t next to each 
other, you can Control-click (Windows) or Command-
click (Mac OS) the names of the rules. 


4. Right-click (Windows) or Control-click (Mac OS) the 
selected rule(s) and select Move CSS Rules in the 
context menu. 


 The Move To External Style Sheet dialog box opens 
(Figure 17). 


5.  Select A New Style Sheet and then click OK. 


 The Save Style Sheet File As dialog box opens 
(Figure 18). 


6. Browse to a location for the CSS file, enter a name for 
the file, and click Save. 


 Note: It is good practice to place CSS files in their own 
folder and good practice to name that folder “css.” 


 Dreamweaver exports the CSS file. 


 


 
Figure 16 CSS Styles panel 


 


 
Figure 17 Move To External Style Sheet dialog 
box 


 


 
Figure 18 Save Style Sheet File As dialog box 
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To delete an internal style sheet: 


1. In the CSS Styles panel under All, select <style>. 


2. Click the Delete Embedded Stylesheet button 
(Figure 19). 


 Dreamweaver removes the internal style sheet. If the 
internal style sheet contains any styles still being used 
on the page, the affected text reverts to its default 
formatting, or it takes on the formatting defined in the 
external style sheet. 


 
Figure 19 CSS Styles panel 


Delete Embedded 
Stylesheet button 
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Attaching an external style sheet 
It’s preferable to use external style sheets, especially if you have more than one web page. Once you create an 
external style sheet and attach it to multiple documents, you can instantly change any style in all your documents by 
making changes to the external style sheet. 


Note: Once you start using an external style sheet, it is best to make all text formatting changes through that style 
sheet. If you make formatting changes through the Property inspector, Dreamweaver will automatically create a new 
internal style sheet. 


1. Open a document. 


2. Make sure the CSS Styles panel is open. 


 If it is not, select Window > CSS Styles. 


3. Click the Attach Style Sheet button (Figure 20). 


 The Attach External Style Sheet dialog box opens 
(Figure 21). 


4. Click Browse, navigate to your saved style sheet, select 
it, and click OK (Figure 22). 


 
Figure 20 CSS Styles panel 


 


 
Figure 21 Attach External Style Sheet dialog box 


 


 
Figure 22 Selecting a CSS style sheet to attach 


Attach Style  
Sheet 
b  
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5. In the Attach External Style Sheet dialog box, click OK 
(Figure 23). 


 Dreamweaver attaches the style sheet to your document 
(Figure 24). 


 The style sheet’s rules are now available in the Property 
inspector. You may need to expand the style sheet to see 
its rules. 


 You can attach the same style sheet to multiple 
documents. When you make changes to the style sheet, 
those changes will appear in all documents the style 
sheet is attached to. 


 
Figure 23 Confirming style attachment 


 


 
Figure 24 Attached style sheet 
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Creating external style sheets 
You can also create external style sheets.  


1. Start Dreamweaver. 


2. Create a new HTML document. 


3. Save and name the Dreamweaver document. 


4. Make sure the CSS Styles panel is open (Figure 25). 


 If it is not, select Window > CSS Styles. 


5. To create a new style, click the New CSS Rule 
button (+) at the bottom of the panel. 


 The New CSS Rule dialog box opens. 


6. Select one of the following types of styles: 


• Class (Can Apply To Any HTLM element). Make 
your own HTML tag by naming a new style and 
defining its formatting. 


o In the Selector Type pop-up menu, select Class. 


o Type a name in the Selector Name box. 


Note: Class names typically begin with a 
period and do not have spaces or special 
characters. Example: .highlight (Figure 26). 


• Tag (Redefines an HTML Element). Change the 
default format of any tag in a document. 


o In the Selector Type pop-up menu, select Tag. 


o In the Selector Name pop-up menu, select the 
type of tag to redefine (for example, H1 tag, 
Body, or Table) (Figure 27). 


 
Figure 25 CSS Styles panel 


 


 
Figure 26 Create your own HTML tag (class) 


 


 
Figure 27 Modify an existing tag 
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• ID (Applies To Only One HTML Element). 


o In the Selector Type pop-up menu, select ID. 


o Type a name in the Selector Name box. 


• Compound (Based On Your Selection). 


o In the Selector Type pop-up menu, select 
Compound. 


o In the Selector Name pop-up menu, select the 
type control to apply to linked text  
(Figure 28). 


 Link controls the normal state of the link. 
The default color is blue. 


 Visited controls the link format after a 
visitor has clicked it. The default color is 
purple. 


 Hover controls the link format as the 
mouse moves over the link. The default 
color is red. 


 Active controls the link format while it is 
being clicked. The default color is red. 


8. In the Rule Definition pop-up menu, select New Style 
Sheet File. 


9. Click OK. 


 The Save Style Sheet File As dialog box opens 
(Figure 29). 


10. Name and save the style sheet in your local root folder. 


11. Make sure Site Root is selected in the Relative To box. 


12. Click Save. 


13. Use the CSS Rule Definition dialog box to set the 
formats for the new style. 


14. Click OK. 


 The new external style sheet is automatically attached to 
the current document and listed in the CSS Styles panel 
(Figure 30). 


 
Figure 28 Create a Compound style 


 


 
Figure 29 Save Style Sheet File As dialog box 


 


 
Figure 30 New external style sheet 


Style sheet 
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Edit styles 


1. To view a style sheet’s rules, click the plus symbol 
beside the style sheet you want to edit in the CSS Styles 
panel. 


 Dreamweaver displays style sheet’s rules.  


2. Select the rule you want to edit. 


3. At the bottom of the CSS Styles panel, click the Edit 
Rule button (Figure 31). 


 The CSS Rule Definition dialog box for the selected 
style opens (Figure 32). 


4. Make formatting changes in the CSS Rule Definition 
dialog box. Then click OK. 


 The changes take effect immediately. Because you 
editing an external style sheet, the same changes are 
applied to any other documents attached to this style 
sheet. 


 
Figure 31 CSS Styles panel 


 


 
Figure 32 CSS Rule Definition dialog box 


 


Edit Rule 
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How to use templates 
You can use an Adobe Dreamweaver CS4 template document to create multiple pages with the same layout. In a 
template, you control which page elements should remain constant in documents based on that template and which 
elements can be changed from page to page. Templates are helpful for building a website in which most pages have 
the same header, navigation system, and other elements. Using templates helps you save time as well as create and 
maintain a consistent look when more than one person is developing a site. 


Creating a template 


1. Start Dreamweaver. 


2. Build a page that contains elements designed to appear 
on all content pages such as common graphics, a 
navigation bar, and common layout structures such as 
tables (Figure 1). 


 Note: You may want to create navigation elements in 
Adobe Fireworks CS4 and export them as HTML 
documents. 


3. Select File > Save As Template. 


4. In the Save As Template dialog box (Figure 2), give the 
template a name. You can also enter a brief description 
of the template. Then click Save. If Dreamweaver asks if 
you want to update links, click Yes. 


 Dreamweaver creates a Templates folder in your site 
root folder and saves your template in that folder. 
Template files have a .dwt file extension. 


 
Figure 1 Common elements on a web page 


 


 
Figure 2 Save As Template dialog box 
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To create an editable region: 


Editable regions in a template are the parts of the page layout that can be changed in files based on the template. 
Locked (non-editable) regions are the parts of the page layout that remain constant from page to page. All regions in 
a new template are locked, so to make the template useful, you must make some regions editable. 


1. In the Layout category of the Insert bar, click Draw AP 
Div, and then drag on the page to create a new div to 
represent the editable region in the template. 


 Note: You also click to indicate where to place the 
editable region, but using a div gives you more control 
over page layout.  


2. With the div still selected, do one of the following to 
create an editable region: 


• Select Insert > Template Objects > Editable Region. 


• Right-click (Windows) or Control-click (Mac OS) 
the region and select Templates > 
New Editable Region from the context menu. 


• In the Common category of the Insert bar, click the 
Templates button (Figure 3), and select 
Editable Region from the pop-up menu. 


 The New Editable Region dialog box opens (Figure 4). 


3. In the dialog box, enter a unique name for the region, 
and click OK. 


 The editable region is within the selected div, and is 
enclosed in a light blue rectangle on the template 
(Figure 5). 


 Note: You cannot use the same name for more than one 
editable region in a particular template. Use only letters 
and numbers in the name. 


4. Save and close the template. 


 
Figure 3 Templates button on the Insert bar 


 


 
Figure 4 New Editable Region dialog box 


 


 
Figure 5 New editable region inside the div 


Templates 
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To create a document based on a template: 


Once you create a template, you can use it to create new documents. 


1. Select File > New. 


2. In the New Document dialog box, select the Page From 
Template category. 


 The dialog box displays your sites and all of the 
templates for the selected site. (Figure 6). 


3. In the Sites list, select the site that contains the template 
you want to use. 


4. Select the template you want to use. 


5. Make sure the Update Page When Template Changes 
option is selected. 


 With this option selected, Dreamweaver can update all 
template-based pages if you change the template later. 


6. Click Create to create a new template-based page. 


 The document opens in the Document window. 


 
Figure 6 Page From Template category in the 
New Document dialog box 


Editing a template 
You can edit a template at any time, even if you have created pages based on the template. 


1. Select Window > Assets. 


 The Assets panel opens. 


2. Click the Templates button on the left side of the panel 
(Figure 7). 


 A list of the templates for your site appears in the lower 
pane. The upper pane displays a preview of the selected 
template. (You may need to scroll the preview pane to 
see this.) 


3. Select the template you wish to edit and do one of the 
following: 


• Double-click the name of the template. 


• Click the Edit button at the bottom of the panel 
(Figure 7). 


4. Edit the template in the Document window, changing 
non-editable elements or creating editable regions in the 
template as desired. 


5. Save the edited template by choosing File > Save. 


 The Update Template Files dialog box opens, with a list 
of the documents based on your template (Figure 8). 


 
Figure 7 Assets panel 


 


 
Figure 8 Update Template Files dialog box 


Templates 


Edit 
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6. Click Update to update the documents based on the 
changes you made in your template. 


 If you have renamed or deleted any editable regions, the 
Inconsistent Region Names dialog box opens 
(Figure 9). It lists the regions in the documents based on 
the template that no longer exist in the template. 


 Note: If you have enabled check in/check out, and the 
files to be updated are currently checked in, 
Dreamweaver asks to check these out before it can 
update them. 


7. Select a region from the list. 


8. In the Move Content To New Region menu, select a new 
region in which you want to place the content from the 
selected region (Figure 9). 


9. Repeat steps 7 and 8 for the remaining regions in the 
list. 


10. Click OK. 


 The Update Pages dialog box displays a summary of the 
updates performed (Figure 10). You may need to select 
Show log to view the Status information. 


11. Click Close. 


 
Figure 9 Inconsistent Region Names dialog box 
with Move Content To New Region menu 


 


 
Figure 10 Update Pages dialog box 


Deleting a template 
1. Select the template in the Assets panel. 


2. Click the Delete button (trash can icon) at the bottom of the panel and confirm that you want to delete the 
template. 


 The template file is deleted from your site. 


 Documents that were based on a template you have deleted retain the structure and editable regions the template 
file had before you deleted it. To turn such a document into a normal HTML file without editable or locked 
regions, you must detach it from the template. 


Detaching from a template 
To remove the template structure and constraints from a document based on a template, you can detach the 
document from the template. When a document is detached from its template, you can edit any element, including 
the regions that were previously locked. 


1. To detach a document from a template, open the document. 


2. Select Modify > Templates > Detach From Template. 
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How to add Flash movies and Flash video to a website 
To add interest and interactivity, you can add movies created in Adobe Flash CS4 and Flash video to your site. Flash 
movies contain animated and interactive content, while Flash videos incorporate video from other sources, such as a 
video camera. For example, you might add an instructional Flash movie about model rocketry, or a slide show, or 
some video that documents a community event. 


Adding Flash movies (SWF files) 


1. Start Adobe Dreamweaver and open the document in 
which you want to insert the Flash movie. 


2. Make sure the Common category in the Insert bar is 
selected. 


3. Click the down arrow on the Media button and select 
SWF in the pop-up menu (Figure 1). 


 The Select File dialog box opens (Figure 2). 


 


 
Figure 1 Media pop-up menu 


 


 
Figure 2 Select File dialog box 
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4. Locate and select the Flash movie (SWF), and then click 
OK (Windows) or Choose (Mac OS). 


 The Object Tag Accessibility Attributes dialog box 
opens (Figure 3). 


5. In the Title text box, type a brief title to identify the 
movie’s contents. Then click OK. 


 A Flash content placeholder, rather than a scene from 
the Flash movie itself, appears in your document 
(Figure 4). This is because the page is pointing to the 
Flash SWF file. When a visitor opens this page, the 
browser plays the SWF file. 


 


 
Figure 3 Object Tag Accessibility Attributes 
dialog box 


 


 
Figure 4 Flash content placeholder 


To set play options: 


To determine how the movie plays when the page loads, you set options in the Property inspector (Figure 5). 


6. Make sure the Flash content placeholder is selected. 


7. In the Property inspector (Figure 5), select the Loop 
option to cause the movie to repeat as long as the visitor 
is on the page. Or, if you don’t want the movie to loop, 
make sure that the Loop option is not checked. 


8. Select the Autoplay option to cause the movie to play 
when the page loads. 


9. To test the movie, click Play. 


 Dreamweaver plays the Flash file in the document, 
showing you what visitors will see when they view the 
page in a browser 


10. When you are finished viewing the Flash movie, click 
Stop in the Property inspector. 


 
Figure 5 Flash Property inspector 
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Adding Flash video (FLV files) 
Flash video plays like any other video content. When you add Flash video, Dreamweaver also inserts a set of 
playback controls. These controls appear in a browser when a visitor opens the page. 


1. Click the down arrow on the Media button on the Insert 
bar and select FLV from the pop-up menu. 


 The Insert FLV dialog box opens (Figure 6). 


2. Click the Browse button beside the URL text box. 


3. Locate and select the Flash video (FLV), and then click 
OK (Windows) or Choose (Mac OS). 


4. Make sure Progressive Download Video is selected in 
the Video Type menu at the top of the dialog box.  


 The Progressive Download Video option enables 
visitors to see movies as they download instead of 
waiting until after the entire movie has downloaded. 


 Note: The Streaming Video option requires the use of 
Adobe® Flash® Media Server. 


5. Click the Detect Size button to fill in the Width and 
Height boxes. 


 Dreamweaver requires this information to include the 
video. 


6. Select a skin from the Skin pop-up menu. 


 This determines the appearance of the Flash video 
playback controls (Figure 7). 


7. Select the Auto Play option to cause the video to play 
when the page loads. 


8. Select the Auto Rewind option to cause the video to 
rewind automatically when it reaches the end. 


9. Click OK to close the dialog box and insert the video. 


 A Flash Video placeholder appears in your document 
(Figure 8). 


10. Save the document.  


 Note: If the Copy Dependent Files dialog box opens, 
click OK to copy the necessary scripts to your site for 
proper playback of the video. 


11. Select File > Preview In Browser and select a browser 
from the submenu to preview the page and test the 
video. 


 
Figure 6 Insert Flash Video dialog box 


 


 
Figure 7 Flash video in a browser with Clear Skin  
selected 


 


 
Figure 8 Flash Video placeholder 
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How to create forms 
You can use forms to interact with or gather information from site visitors. With forms, visitors can provide 
feedback, sign a guest book, take a survey, or place an order for merchandise. In Adobe Dreamweaver CS4, you can 
create a variety of form elements, such as text fields, password fields, radio buttons, checkboxes, pop-up menus, and 
clickable images (such as a Submit button). 


The Forms category in the Insert bar (Figure 1) contains buttons for creating forms and inserting form elements. 


 
Figure 1 Forms category in the Insert bar 


The data gathered in forms is usually sent to a database on a server or through e-mail. To set up the form processing, 
contact your site administrator. This guide helps you make the user interface of a form. 
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Setting up a form 


1. Open a page in Dreamweaver. 


2. Place the insertion point on the page where you want to 
insert a form or draw a new div for more precise 
positioning of the form on your page.  


 Note: To draw a new div, click Draw AP Div in the 
Layout category in the Insert bar, and then drag to draw 
the div. Be sure to make the div large enough to contain 
the entire form you plan to create. 


3. Select the Forms category in the Insert bar (Figure 1), 
and click Form.  


 A blank form appears, with a red dotted outline 
(Figure 2). You place all form elements inside this 
outline. If you placed the form inside a div, you may 
need to click outside the div to see the entire form 
outline. 


 Form options appear in the Property inspector. 


4. From the Method pop-up menu in the Property inspector 
(Figure 3), select either GET or POST. 


• GET appends the form contents to the URL 
specified in the Action text box. Use GET if the 
form data is short and the results of the form will 
lead to a page that you want the visitor to be able to 
bookmark. 


• POST sends the form contents directly to the server 
in a manner that is not visible to the visitor. Use 
POST if the form data might be long (if, for 
instance, the form includes a text field that the 
visitor can use to type an unlimited amount of text).  


5. In the Action text box, type the URL or CGI script that 
will process the form. 


 Note: Get this information from your site administrator. 


 
Figure 2 Blank form 


 


 
Figure 3 Method menu in the Property inspector 


Adding form elements 
Using the Forms category in the Insert bar, you can insert any combination of form elements within the red outline 
of the form. You can use tables to lay out these elements if you choose. 


Using form fields 


Form fields enable site visitors to enter text into a form. Form fields include the following: 


• Text fields, in which a visitor types a response 


• File fields, in which a visitor types the path of a file to upload to your server 
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To add a text field: 


Text fields provide a space in which visitors can enter text. 


1. Click the Text Field button in the Insert bar. 


 The Input Tag Accessibility Attributes dialog box opens 
(Figure 4). 


2. In the Input Tag Accessibility Attributes dialog box, 
enter a unique name for the text field in the ID text box. 
You may use any combination of letters, numbers, and 
an underscore (_). 
 
The ID is used by HTML and/or Javascript code to 
distinguish this input tag from others, but it isn’t visible 
to site visitors. 


3. Enter a label for the text field in the Label text box. You 
can leave the other properties in the dialog box at their 
default values.  
 
The label will be displayed next to the text field, 
indicating to the visitor what to put in the field. 


4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box. 


 The text field appears in the form (Figure 5). 


5. Click in the text field (not the label) to select it. 


6. In the form Property inspector (Figure 6), select one of 
the three types of text fields: 


• Single Line text for short answers 


• Multi Line text for long answers such as the 
visitor’s description of a problem with a purchased 
item 


• Password text for passwords (in which asterisks 
appear in place of typed characters) 


 Note: You can also create a multiple-line text field by 
clicking the Text Area button in the Insert bar. 


 
Figure 4 Input Tag Accessibility Attributes dialog 
box 


 


 
Figure 5 Example of text field in the form 


 


 
Figure 6 Form Text Field Property inspector 
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To add a file field: 


A file field enables site visitors to select a file on their computers (such as a word-processing document or graphics 
file) and upload it to your server. A file field looks like other single-line text fields, except it also provides a Browse 
button. The visitor either types the path to the file they want to upload or uses the Browse button to locate and select 
the file. 


1. Click the File Field button in the Insert bar. 


 The Input Tag Accessibility Attributes dialog box opens. 


2. In the Input Tag Accessibility Attributes dialog box, 
enter a unique name for the file field in the ID text box. 
You may use any combination of letters, numbers, and 
an underscore (_). 


3. Enter a label for the file field in the Label text box. You 
can leave the other properties in the dialog box at their 
default values.  


4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box. 


 The file field appears in your document (Figure 7). 


5. Click in the file field (not the label) to select it. In the 
Property inspector, in the Char Width text box, specify 
the maximum number of characters visitors will see in 
the field (Figure 8). 


6. In the Max Char text box, specify the maximum number 
of characters the field will hold. 


 Note: Contact your site administrator to confirm that 
anonymous file uploads are allowed before using the file 
field. 


 
Figure 7 Example of file field 


 


 
Figure 8 Form File Field Property inspector 







Adobe Dreamweaver CS4 Activity 3.7 guide 


© 2008 Adobe Systems Incorporated How to create forms 5 


Using checkboxes and radio buttons 
Visitors click a checkbox or radio button to make a choice. With checkboxes, visitors can toggle a single option on 
or off, or they can select one or more options from a group of options. With radio buttons, visitors can select only 
one option from a group of options. 


To add a checkbox: 


1. Click the Checkbox button in the Insert bar. 


 The Input Tag Accessibility Attributes dialog box opens. 


2. In the Input Tag Accessibility Attributes dialog box, 
enter a unique name for the checkbox in the ID text box. 
You may use any combination of letters, numbers, and 
an underscore (_). 


3. Enter a label for the checkbox in the Label text box. You 
can leave the other properties in the dialog box at their 
default values.  


4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box. 


 The checkbox button appears in your document 
(Figure 9). 


5. Click the checkbox (not the label) to select it. 


6. In the Checked Value text box in the Property inspector 
(Figure 10), enter a value for the checkbox. 


 This is the value that will be returned by the form. For 
example, for a checkbox that indicates whether a visitor 
wishes to be on a mailing list, you might set a value of 1 
for yes. 


7. For Initial State, select Checked if you want an option to 
appear selected when the form first loads in the visitor’s 
browser. Otherwise, select Unchecked. 


 
Figure 9 Example of checkbox 


 


 
Figure 10 Form Checkbox Property inspector 
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To add a group of radio buttons: 


Radio buttons are typically used in groups. 


1. Click the Radio Group button in the Insert bar to insert a 
group. 


 The Radio Group dialog box opens (Figure 11). 


2. Enter a name in the Name text box. 


3. Click the plus (+) button to add a radio button to the 
group. 


4. Enter a label and (if you want) a checked value for each 
button. 


5. Select an item in the radio button list, and click the up or 
down arrows to reorder the buttons. 


6. Select Line Breaks to arrange the radio buttons without 
using a table. Select Table to arrange them in a table.  


7. Click OK. 


 The group of radio buttons is added to the form 
(Figure 12). 


8. Click a radio button (not its label) to select it. 


9. In the Property inspector, click Checked or Unchecked 
to indicate if this option is selected by default 
(Figure 13). 


 
Figure 11 Radio Group dialog box 


 


 
Figure 12 Example of Radio Group 


 


 
Figure 13 Form Radio Button Property inspector 
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Using lists and menus (List/Menu) 
Lists and menus allow visitors to select options from a list or pop-up menu. With a list menu, you can display 
multiple options in a confined space and allow visitors to select multiple items. Visitors can select only one item 
from a pop-up menu. 


To add a list menu: 


1. Click the List/Menu button in the Insert bar. 


 The Input Tag Accessibility Attributes dialog box opens. 


2. In the Input Tag Accessibility Attributes dialog box, 
enter a unique name for the list menu in the ID text box. 
You may use any combination of letters, numbers, and 
an underscore (_). 


3. Enter a label for the list menu in the Label text box. You 
can leave the other properties in the dialog box at their 
default values.  


4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box. 


 A list/menu field appears in your document (Figure 14). 


5. Click the list/menu field (not its label) to select it. 


6.  In the Property inspector, for Type, select List 
(Figure 15). 


7. In the Height text box, enter the number of items the list 
will display. 


 If this number is less than the total number of items in 
the list, a scroll bar will be displayed. 


8. If you want to allow visitors to select more than one 
item in the list, select Allow Multiple for Selections. 


9. Click the List Values button to add the list items. 


 The List Values dialog box opens (Figure 16). 


10. With the insertion point in the Item Label text box, enter 
the text you want to appear in the list. 


11. In the Value text box, enter data you want sent to the 
server when a visitor selects the item. 


 If you enter no value, then the form sends the label as 
the value for that item. 


12. To add another item to the list, click the plus (+) button. 


13. When you finish, click OK to close the List Values 
dialog box. 


14. To have one of the items in the list selected by default, 
select that item in the Initially Selected text box in the 
Property inspector (Figure 17). 


 The Initially selected item is highlighted in the list 
(Figure 18). 


 
Figure 14 Example of list/menu field 


 


 
Figure 15 Form List Menu Property inspector 


 


 
Figure 16 List Values dialog box  


 


 
Figure 17 Choose which item is initially selected 


 


 
Figure 18 Form list with three items in the list 
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To add a drop-down menu: 


1. Click the List/Menu button in the Insert bar. 


 The Input Tag Accessibility Attributes dialog box opens. 


2. In the Input Tag Accessibility Attributes dialog box, 
enter a unique name for the pop-up menu in the ID text 
box. You may use any combination of letters, numbers, 
and an underscore (_). 


3. Enter a label for the pop-up menu in the Label text box. 
You can leave the other properties in the dialog box at 
their default values.  


4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box. 


 A list/menu field appears in your document (Figure 19). 


5. Click the list/menu field (not its label) to select it.  


6. In the Property inspector, for Type, select Menu. 


7. Click the List Values button to add the menu items. 


 The List Values dialog box opens (Figure 20). 


8. With the insertion point in the Item Label text box, enter 
the text you want to appear in the menu. 


9. In the Value text box, enter data you want sent to the 
server when a visitor selects the item. 


10. To add another item to the menu, click the plus (+) 
button. 


11. When you finish, click OK to close the List Values 
dialog box. 


12. To have one of the items in the menu selected by 
default, select that item in the Initially Selected text box 
in the Property inspector.  


 Note: To see these values on the page, you need to 
preview this page in a browser (Figure 21). 


 
Figure 19 A list/menu field 


 


 
Figure 20 List Values dialog box 


 


 
Figure 21 Preview in a browser 
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Using form buttons 
Form buttons control form operations. Use a form button to submit data entered into a form to the server or to reset 
the form. There are two types of form buttons: Standard text buttons are the browser’s default button style, with text 
you want to display (typically Submit, Send, or Reset); graphical buttons use the graphic of your choice. 


To add a standard text button: 


1. Click the Button button in the Insert bar. 


 The Input Tag Accessibility Attributes dialog box opens. 


2. In the Input Tag Accessibility Attributes dialog box, 
enter a unique name for the button in the ID text box. 
You may use any combination of letters, numbers, and 
an underscore (_). 


 Note: There are two reserved names: Submit, which 
submits the form data for processing, and Reset, which 
resets all the form fields to their original values. 


3. Don’t enter a label for the button. Click OK to close the 
Input Tag Accessibility Attributes dialog box. 


 Note: A label would appear next to the button, rather 
than on it, so you don’t want a label for a button form 
element. The text on the button itself is set by the 
button’s value attribute, which you will set in the next 
step. 


 A text button appears in the document (Figure 22). 


 Note: In this example, a Submit button is placed below 
an existing file field. 


4. Click the button to select it. 


5.  In the Property inspector’s Value text box, enter the text 
you want to appear on the button (Figure 23). 


 Note: It’s a good idea to set the value to whatever the 
button does. “Submit” is a good choice, but you might 
also consider brief phrases in the forms of commands 
(for example, “Send Message” or “Update Profile” or 
“Register”). 


6. Select the type of Action (usually this is Submit Form). 


 
Figure 22 Example of text button 


 


 
Figure 23 Form Button Property inspector 
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To add a graphical submit button: 


You can use images as submit button icons. Using an image to perform tasks other than submitting data requires 
attaching a behavior to the form object by using the Behaviors panel. 


1. Click the Image Field button in the Insert bar. 


 The Select Image Source dialog box appears 
(Figure 24). 


2. Locate and select the image to use as the submit button 
icon; then click OK (Windows) or Choose (Mac OS). 


 The Input Tag Accessibility Attributes dialog box opens. 


3. In the Input Tag Accessibility Attributes dialog box, 
enter a unique name for the button in the ID text box. 
You may use any combination of letters, numbers, and 
an underscore (_). 


 Note: There are two reserved names: Submit, which 
submits the form data for processing, and Reset, which 
resets all the form fields to their original values. 


4. Don’t enter a label for the button. Click the OK button 
to close the Input Tag Accessibility Attributes dialog 
box. 


 The graphical submit button appears in your document 
(Figure 25). 


5. Click the button to select it. 


6. In the Alt text box, type alternate text you want to 
appear in place of the image for text-only browsers 
(Figure 26). This should match any text displayed on 
the button. 


 Note: You can also click the folder icon beside the Src 
text box to select a new image for the button. 


 
Figure 24 Select Image Source dialog box 


 


 
Figure 25 Example of graphical submit button  


 


 
Figure 26 Form Image Field Property inspector 
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Using jump menus for navigation 
A jump menu is a pop-up menu with options that link to documents or files. It is a form element that acts as 
navigation. You can create links to documents in your website or other websites, e-mail links, links to graphics, or 
links to any file type that can be opened in a browser. Because using this type of menu will cause the browser to 
navigate to another page, don’t mix jump menus with other form elements. 


To add a jump menu: 


1. Click the Jump Menu button in the Insert bar. 


 The Insert Jump Menu dialog box opens (Figure 27). 


2. Complete the dialog box. 


 For more information, click the Help button in the 
dialog box. 


3. Click OK. 


 
Figure 27 Insert Jump Menu dialog box 
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How to make websites accessible 


Alternate text 
Alternate text for images is critical for many devices that assist disabled people to access the web. The Property 
inspector in Adobe Dreamweaver CS4 has an Alt text box for entering alternative text for an image, link, or button. 
The text can be descriptive and as long as necessary, but it should be as succinct as possible. 


 


Cascading Style Sheets (CSS) 
Developers use CSS to separate content from presentation of their websites, allowing assisting devices easier access 
to the information provided in the content. Developers also use CSS to create a consistent structure for text content, 
aiding interpretive devices (such as text-to-speech browsers). 


Image maps 
Provide alternate text for hot spots in images to make them readable by interpretive devices. 


  


Tables 
Provide alternate text descriptions for tables, such as identifiers of row and column headings for data tables or longer 
descriptions for tables with textural information. 


Templates and library objects 
Designers can create a single, accessible template or a small set of templates as the basis of the entire site. Templates 
limit mistakes when multiple designers are working on a site. In addition, templates foster a consistent, easy-to-use 
site that keeps visitors oriented and has consistent common elements such as navigation bars. 


Frames 
Add descriptions of frames in the Adobe Dreamweaver CS4 Property inspector. This alternative text provides 
additional information to web browsers and readers as visitors navigate each frame. 
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Movies 
Use the Accessibility panel in Adobe Flash CS4 to provide text equivalents where appropriate. If there are movie 
elements that are purely decorative, are repetitive, or otherwise convey no content, then make those elements 
inaccessible by deselecting the option, “Make Object Accessible.” Use the Description section of the panel to 
provide context for the entire movie. 


Device independence 
Device independence means that your web page should not require a particular hardware device in order to use it. 
For instance, the page should not require that the user have a mouse in order to use it—all controls should be 
manageable from the keyboard. Provide a keyboard equivalent for each button, and include all links and buttons in 
the tab index, so that visitors can use the Tab key to move from one element to the next.  


Use the Behaviors panel in Dreamweaver to create rollovers and other scripts that are triggered by logical events, 
such as onFocus and onBlur. Create scripts that combine mouse events with logical events to support a variety of 
visitors. For more about behaviors, see “Adding JavaScript behaviors” in Dreamweaver Help (in Dreamweaver, 
select Help > Dreamweaver Help). 
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How to check links 
A key technical testing task is to check all the links. Adobe Dreamweaver CS4 enables you to do this automatically. 


1. Start Dreamweaver. 


2. Make sure your site is open. 


3. On the menu bar, select Site > Check Links Sitewide. 


 The Link Checker tab displays all the broken links in the site (Figure 1). 


 
Figure 1 Link Checker tab 


 Note: Even though links are listed as broken, check them in the browser to confirm. 


4. Fix the broken links and check the links again. 


 Note: To clear the current Link Checker results, select Clear Results from the Link Checker Options menu. 
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How to publish web files 
After you finish editing your documents, you need to publish them to your web server so the documents can be 
viewed. 


Connecting to a remote site 
Many websites let you publish files through FTP (File Transfer Protocol). You connect to a remote site by using the 
Site Definition dialog box in Adobe Dreamweaver CS4. 


1. Select Site > Manage Sites from the menu bar. 


 The Manage Sites dialog box opens (Figure 1). 


2. Select the name of the site you want to connect 
remotely, and click Edit. 


 The Site Definition dialog box opens. 


3. Click the Advanced tab and select the Remote Info 
category in the Site Definition dialog box (Figure 2). 


4. Select FTP in the Access pop-up menu. 


5. Enter the FTP access information as directed by your 
teacher. 


6. Click Test to test the connection. 


 Dreamweaver confirms the connection. 


7. Click OK. 


8.  Click Done to close the Manage Sites dialog box. 


 


 
Figure 1 Manage Sites dialog box 


 


 
Figure 2 Site Definition dialog box 
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Uploading and downloading files 
Once you establish an FTP connection, you can publish files directly from the Files panel. 


Uploading the entire site for the first time 


1. Make sure the Files panel is open (Figure 3). 


 The Files panel is typically located on the right side of 
the screen. If the Files panel is not open, select 
Window > Files. 


2. Click the Expand/Collapse button in the Files panel 
toolbar (Figure 3). 


 The Files panel expands (Figure 4). 


3. Make sure the Connects To Remote Host button is 
active (Figure 5). Click it if necessary. 


 Dreamweaver connects to the web server. 


4. Select the root folder for your site in the Local (right) 
pane. 


5. Click the Put Files button (the upward-pointing arrow). 


 Dreamweaver uploads the site’s files and opens the 
Background File Activity dialog box (Figure 6). 


 Note: To upload one or more folders or files without 
uploading the entire site, select them and click the Put 
Files button. 


 


 


 
Figure 3 Files panel 
 


 
Figure 4 Expanded Files panel 


 


 


 
Figure 5 Connect To Remote Host and Put 
buttons 
 


 
Figure 6 Background File Activity dialog box 


Expand/Collapse button 


Put button Connects To Remote Host 
button 
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Uploading a revised version of an existing file 


1. Select the file you have revised. 


2. Click the Put Files button. 


 Dreamweaver uploads the revised file. 


 


Downloading files to work on them 


Once your website has been published, you will often want to download a file so you can revise it. You do so 
through the Remote Site pane, on the left side of the expanded Files panel. 


1. Click the Refresh button (Figure 7) to make sure the 
files in the Remote Site pane are up-to-date. 


2. Select a file to download. 


3. Click the Get Files button (Figure 7). 


 If the file has any dependent files, the Dependent Files 
dialog box opens (Figure 8). Dependent files are files, 
such as images or Flash movies, incorporated into a web 
page. In most cases, you need to download these in 
order for a web page to appear correctly. 


4. Click Yes. 


 Dreamweaver copies the file and its dependent files to 
your local folder. The downloaded files appear in the 
right pane of the expanded Files panel. 


5. Click the Disconnects From Remote Host button  
(Figure 7), and then collapse the Files panel. 


 


 


 


 
Figure 7 Get button 


 


 
Figure 8 Dependent Files dialog box 
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